summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-01-16 20:06:08 +0100
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-01-16 23:20:15 +0100
commit9928ea5c84889026f5800fe4270013791d47f16a (patch)
tree265451336594a920a08f5bab1d8bd17477406c9d /Makefile.am
parent083a75be98d83517afdaa3da9ada22adb106cb1a (diff)
parent3d6197fe647445ecbcfaac6c004449246471d5b6 (diff)
downloadautomake-9928ea5c84889026f5800fe4270013791d47f16a.tar.gz
Merge branch 'maint'
* maint: recheck: fix interaction with "make -n" vala: avoid potential useless remakes (minor bugfix) vala: enhance tests recheck: behave better with non-GNU make check: separate .log -> .html conversion from core testsuite harness docs: deprecate .log -> .html conversion by parallel-tests tests: list some forgotten test cases in $(TESTS) maintcheck: consistency of list of test scripts build: explicitly declare some targets as .PHONY maint: remove obsolete/broken maintainer targets build: improve silencing of automake build system tests: move list of tests in its own Makefile fragment + Extra non-trivial edits: * tests/parallel-tests2.test: Obvious edits to merge the slightly inconsistent enhancements to coverage done in master with those done in maint. * lib/am/check.am (check-TESTS, recheck): Sweeping and rather complex changes to merge the considerable divergences between maint and master in a way that is meaningful and, where possible, retains the semantic changes from both maint and master.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am37
1 files changed, 8 insertions, 29 deletions
diff --git a/Makefile.am b/Makefile.am
index 00ed606ac..ab57068ce 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -93,11 +93,9 @@ do_subst = sed \
automake: automake.in
aclocal: aclocal.in
automake aclocal: Makefile
- $(AM_V_GEN)rm -f $@ $@.tmp
- $(AM_V_at)$(do_subst) $(srcdir)/$@.in >$@.tmp
- $(AM_V_at)chmod +x $@.tmp
- $(AM_V_at)chmod a-w $@.tmp
- $(AM_V_at)mv -f $@.tmp $@
+ $(AM_V_at)rm -f $@ $@-t
+ $(AM_V_GEN)$(do_subst) $(srcdir)/$@.in >$@-t
+ $(AM_V_at)chmod a+x,a-w $@-t && mv -f $@-t $@
## The master location for INSTALL is lib/INSTALL.
## This is where `make fetch' will install new versions.
@@ -271,14 +269,15 @@ sc_unquoted_DESTDIR \
sc_tabs_in_texi \
sc_at_in_texi
-.PHONY: $(syntax_check_rules)
$(syntax_check_rules): automake aclocal
+maintainer-check: $(syntax_check_rules)
+.PHONY: maintainer-check $(syntax_check_rules)
## Check that the list of tests given in the Makefile is equal to the
## list of all test scripts in the Automake testsuite.
.PHONY: maintainer-check-list-of-tests
maintainer-check-list-of-tests:
- @failcom='exit 1'; \
+ @fail= failcom='exit 1'; \
for f in x $$MAKEFLAGS; do \
case $$f in \
*=* | --[!k]*);; \
@@ -290,7 +289,7 @@ maintainer-check-list-of-tests:
done; \
test -z "$$fail"
-maintainer-check: $(syntax_check_rules) maintainer-check-list-of-tests
+maintainer-check: maintainer-check-list-of-tests
## Look for test whose names can cause spurious failures when used as
## first argument to AC_INIT (chiefly because they might contain an
@@ -814,27 +813,6 @@ git-release: git-dist
$(srcdir)/lib/gnupload $(GNUPLOADFLAGS) \
--to $$dest.gnu.org:automake $(DIST_ARCHIVES)
-git-diff:
- $(AM_V_GEN):; \
- thisver="v$(VERSION)"; \
- if test -z "$$OLDVERSION"; then \
- prevno=`echo "$(VERSION)" - 0.01 | bc | sed 's/^\./0./'`; \
- else prevno="$$OLDVERSION"; fi; \
- prevver=v$$prevno; \
- git diff $$prevver..$$thisver $(PACKAGE) \
- > $(PACKAGE)-$$prevno-$(VERSION).diff
-
-## Check our path lengths.
-path-check: distdir
- $(AM_V_GEN)($(am__cd) $(distdir) && \
-## FIXME there's got to be a better way! pathchk should take the list
-## of files on stdin, at least.
- find . -print | xargs pathchk -p); \
- estatus=$$?; \
- find $(distdir) -type d '!' -perm -200 -exec chmod u+w {} ';'; \
- rm -rf $(distdir); \
- exit $$estatus
-
## Visually comparing differences between the Makefile.in files in
## automake's own build system as generated in two different branches
## might help to catch bugs and blunders. This has already happened a
@@ -952,6 +930,7 @@ fetch:
test $$stat = 0 || \
echo "See Fetchdir/update.patch for a log of the changes."; \
exit $$stat
+.PHONY: fetch
## Generate release statistics, for the table in automake.texi.
## This has to be run in an up to date build tree, but there must