summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexandre Duret-Lutz <adl@gnu.org>2004-01-05 22:21:31 +0000
committerAlexandre Duret-Lutz <adl@gnu.org>2004-01-05 22:21:31 +0000
commitd4a09a87fab2f176a7befadb3b4c8d66655f9ff9 (patch)
treeb13ed9c153bd9c4dca6589c481274d79e8386d21 /Makefile.am
parentaf2cb9d0f88d76f81c6d4d426141ee78eb035238 (diff)
downloadautomake-d4a09a87fab2f176a7befadb3b4c8d66655f9ff9.tar.gz
Mimic Paul Eggert's changes to Autoconf.
* Makefile.am (automake, aclocal): Use `chmod a-w', not `chmod -w'. * lib/Automake/Makefile.am (Config.pm): Likewise. * m4/Makefile.am ($(top_srcdir)/m4/amversion.m4): Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 45bd7ff7c..d2feb6965 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,7 @@
## Makefile for Automake.
-## Copyright (C) 1995, 1996, 1997, 1998, 1999, 2001, 2002, 2003
+## Copyright (C) 1995, 1996, 1997, 1998, 1999, 2001, 2002, 2003, 2004
## Free Software Foundation, Inc.
## This program is free software; you can redistribute it and/or modify
@@ -69,19 +69,19 @@ do_subst = sed \
## These files depend on Makefile so they are rebuilt if $(VERSION),
## $(datadir) or other do_subst'ituted variables change.
-## Use chmod -w to prevent people from editing the wrong file by accident.
+## Use chmod a-w to prevent people from editing the wrong file by accident.
automake: automake.in Makefile
rm -f $@ $@.tmp
$(do_subst) $(srcdir)/automake.in >$@.tmp
chmod +x $@.tmp
- chmod -w $@.tmp
+ chmod a-w $@.tmp
mv -f $@.tmp $@
aclocal: aclocal.in Makefile
rm -f $@ $@.tmp
$(do_subst) $(srcdir)/aclocal.in >$@.tmp
chmod +x $@.tmp
- chmod -w $@.tmp
+ chmod a-w $@.tmp
mv -f $@.tmp $@
## The master location for INSTALL is lib/INSTALL.