summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexandre Duret-Lutz <adl@gnu.org>2006-08-19 15:55:53 +0000
committerAlexandre Duret-Lutz <adl@gnu.org>2006-08-19 15:55:53 +0000
commitd5358968b3ce766396ba5de76eb42454f835b827 (patch)
tree340d2349cb93d80a269a2ba40ce2d3253367afa9 /Makefile.am
parentf5b38979101a2c2c7dfb1fe4732393dec41d3ed1 (diff)
downloadautomake-d5358968b3ce766396ba5de76eb42454f835b827.tar.gz
* Makefile.am (maintainer-check): Check for mkdir_p.
* automake.texi (Obsolete macros): Document AM_PROG_MKDIR_P. * lib/am/data.am, lib/am/distdir.am, lib/am/install.am, lib/am/java.am, lib/am/libs.am, lib/am/lisp.am, lib/am/ltlib.am, lib/am/mans.am, lib/am/progs.am, lib/am/python.am, lib/am/scripts.am, lib/am/texinfos.am: Use MKDIR_P instead of mkdir_p. * m4/mkdirp.m4 (AM_PROG_MKDIR_P): Define mkdir_p using $MKDIR_P, not as '$(MKDIR_P)', otherwise it will break `Makefile.in's that use mkdir_p without defining MKDIR_P. * tests/distdir.test, tests/instman.test, tests/txinfo21.test: Adjust.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ee9c8021c..13ff19546 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -268,6 +268,10 @@ maintainer-check: automake aclocal
echo 'Do not use egrep or fgrep in the above files, they are not portable.' 1>&2; \
exit 1; \
fi
+ @if grep 'mkdir_p' $(srcdir)/lib/am/*.am $(srcdir)/tests/*.test; then \
+ echo 'Do not use mkdir_p in the above files, use MKDIR_P.' 1>&2; \
+ exit 1; \
+ fi
## Try to make sure all @...@ substitutions are covered by our
## substitution rule.
@if test `grep -E '^[^#]*@[A-Za-z_0-9]+@' aclocal | wc -l` -ne 0; then \