summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-04-06 15:20:54 +0200
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-04-06 21:29:31 +0200
commit8e02441b00db75f21455edc92191e64cab19b031 (patch)
tree66d045b7a857d169f5d83be0a5ac526fad5102a8 /configure.ac
parent8a5096d150cf9803b8963768b7366cd68edcce03 (diff)
downloadautomake-8e02441b00db75f21455edc92191e64cab19b031.tar.gz
maint: no more make recursion in Automake's build system
We finally merge testsuite-related part of the Automake build system with the top-level one. See also yesterday's commit 'v1.11-2124-ga4b0f4b', "maint: remove most recursion in automake's own build system". * t/gen-testsuite-part: Move ... * gen-testsuite-part: ... here, with required adjustments. * t/defs-static.in: Move ... * defs-static.in: ... here, with required adjustments. In particular ... ($testsrcdir, $testbuilddir): Removed. ($top_testsrcdir): Renamed ... ($am_top_srcdir): ... to this. ($top_testbuilddir): Renamed ... ($am_top_builddir): ... to this. * t/defs: Move ... * defs: ... here, and adjust as required. * t/Makefile.am: Merge ... * Makefile.am: ... in here, with related adjustments and simplifications. * bootstrap: Adjust as required. * syntax-checks.mk: Likewise. * .gitignore: Likewise. * t/ax/tap-setup.sh: Likewise. * t/get-sysconf.sh: Likewise. * t/help-multilib.sh: Likewise. * t/multlib.sh: Likewise. * t/parallel-tests2.sh: Likewise. * t/self-check-cleanup.tap: Likewise. * t/self-check-exit.tap: Likewise. * t/self-check-dir.tap: Likewise. * t/self-check-explicit-skips.sh: Likewise. * t/self-check-reexec.tap: Likewise. * t/self-check-sanity.sh: Likewise. * t/yacc-d-cxx.sh: Likewise. Signed-off-by: Stefano Lattarini <stefano.lattarini@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 021d4ec03..b566220ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -395,9 +395,11 @@ AC_SUBST([EXEEXT])
###########################################################################
-AC_CONFIG_FILES([Makefile t/Makefile])
+AC_CONFIG_FILES([Makefile])
+
AC_CONFIG_LINKS([GNUmakefile:GNUmakefile])
-AC_CONFIG_LINKS([t/defs:t/defs])
+AC_CONFIG_LINKS([defs:defs])
+
AC_CONFIG_FILES([t/wrap/aclocal-${APIVERSION}:t/wrap/aclocal.in],
[chmod +x t/wrap/aclocal-${APIVERSION}],
[APIVERSION=$APIVERSION])