summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2011-12-15 18:41:22 +0100
committerStefano Lattarini <stefano.lattarini@gmail.com>2011-12-15 18:42:55 +0100
commita9edac6c6e0c33d6571d6ef5ce0bbf682459c3bc (patch)
tree14bce7aefee711a0091807ed548aedead47e9843 /configure.ac
parent91ea62abccb87e2a1ae989bae95640d8913d2970 (diff)
parent30bd6d1e53fbc31ef3431893e4db3efe9ad799ee (diff)
downloadautomake-a9edac6c6e0c33d6571d6ef5ce0bbf682459c3bc.tar.gz
Merge branch 'maint' into 'yacc-work'
Extra edits: * tests/silent-lex.test: Provide a dummy `yywrap()' function, to avoid link errors on systems that doesn't provide a "lex library". See also commit `v1.11-546-gca0ba5d'. Commits merged from maint (34 commits): readme: reference webpages for automake mailing lists readme: update advice about testsuite execution readme: don't reference the old homepage at sources.redhat.com hacking: some more fixlets * NEWS: Fix typo in 'make dist-bzip2' description. release: don't run "make distcheck" automatically hacking: update on-line documentation for stable releases only hacking: described release procedure applies to beta releases too readme: the documentation is production quality now hacking: tell about platform-testers mailing list hacking: we don't use sources.redhat.com anymore hacking: miscellaneous minor fixes dist-xz, dist-bzip2: don't hard-code -9, honor envvar settings news: fix typos, grammaros and suboptimal wording maint: sync auxiliary files from upstream tests: fix spurious failures due to missing 'yywrap()' function depcomp: spelling fix tests: fix 'distcheck-override-infodir.test' on Cygwin cosmetics: typofix in comments coverage: undistributed '.am' and '.m4' files are diagnosed coverage: required but missing '.am' and '.m4' files are diagnosed coverage: expose automake bug#10111 in the testsuite fix: regenerate doc/Makefile texinfo: work around Solaris 10 xpg4 shell bug in install rules configure: report perl version in config.log tests: fix spurious failure with older install-info maintcheck: fix spurious failure in 'color2.test' tests: fix spurious error in 'uninstall-fail.test' on Solaris tests: fix typo in 'uninstall-fail.test' tests: avoid a spurious failure of 'ltinit.test' MinGW tests: testsuite is now safe to run with dmake in parallel mode tests: fix spurious failures w.r.t. parallel make and colorization Merge branch 'fix-pr9579' into maint tests: fix spurious failure in 'distcheck-override-infodir.test' tests: avoid another failure of 'uninstall-fail.test' on Solaris
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d78195134..4a4cc2a04 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,6 +61,8 @@ AC_PATH_PROG(PERL, perl)
if test -z "$PERL"; then
AC_MSG_ERROR([perl not found])
fi
+# Save details about the selected perl interpreter in config.log.
+AM_RUN_LOG([eval $PERL --version])
$PERL -e 'require 5.006;' || {
AC_MSG_ERROR(
[perl 5.6 or better is required; perl 5.8.2 or better