summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-04-06 13:12:25 +0200
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-04-06 21:29:30 +0200
commit8a5096d150cf9803b8963768b7366cd68edcce03 (patch)
treea49c0e54876b8b9877d7ca2df386377e7b6037d1 /configure.ac
parentf8e822bbc197f01fc722aa6def7cddb4182e3c66 (diff)
downloadautomake-8a5096d150cf9803b8963768b7366cd68edcce03.tar.gz
tests: rename 'tests/' => 't/', '*.test' => '*.sh'
When we (soon) convert the Automake testsuite to a non-recursive make setup, we'll have to fix the entries of $(TESTS) to be prepended with the subdirectory they are in; this will increase the length of $(TESTS), and thus increase the possibility of exceeding the command-line length limits on some systems (most notably, MinGW/MSYS). See automake bug#7868 for more information. Thus we rename the 'tests/' subdirectory to 't/', and each 'x.test' script in there to 'x.sh'; this way, the $(TESTS) entry 'foo.test' will become 't/foo.sh', which have the same number of characters. * tests/: Rename ... * t/: ... to this. * t/*.test: Rename ... * t/*.sh: ... to this. * t/.gitignore: Removed as obsolete. * t/defs: Adjust. * t/gen-testsuite-part: Likewise. * t/list-of-tests.mk: Likewise. * t/ccnoco.sh: Likewise. * t/ccnoco3.sh: Likewise. * t/self-check-cleanup.tap: Likewise. * t/self-check-dir.tap: Likewise. * t/self-check-me.tap: Likewise. * t/self-check-reexec.tap: Likewise. * README: Likewise. * bootstrap: Likewise * configure.ac: Likewise. * Makefile.am: Likewise. * .gitignore: Likewise. * syntax-check.mk: Likewise. Signed-off-by: Stefano Lattarini <stefano.lattarini@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index ae5163fdf..021d4ec03 100644
--- a/configure.ac
+++ b/configure.ac
@@ -217,9 +217,9 @@ else
fi
])
if test $am_cv_sh_errexit_works = no; then
- AC_MSG_WARN(["${MAKE-make} check" will leave leftover directories tests/*.dir])
+ AC_MSG_WARN(["${MAKE-make} check" will leave leftover directories t/*.dir])
AC_MSG_WARN([you can clean them up manually using "${MAKE-make} clean" or])
- AC_MSG_WARN(["cd tests && ${MAKE-make} clean-local-check'])
+ AC_MSG_WARN(["cd t && ${MAKE-make} clean-local-check'])
fi
AC_SUBST([sh_errexit_works], [$am_cv_sh_errexit_works])
@@ -395,14 +395,14 @@ AC_SUBST([EXEEXT])
###########################################################################
-AC_CONFIG_FILES([Makefile tests/Makefile])
+AC_CONFIG_FILES([Makefile t/Makefile])
AC_CONFIG_LINKS([GNUmakefile:GNUmakefile])
-AC_CONFIG_LINKS([tests/defs:tests/defs])
-AC_CONFIG_FILES([tests/wrap/aclocal-${APIVERSION}:tests/wrap/aclocal.in],
- [chmod +x tests/wrap/aclocal-${APIVERSION}],
+AC_CONFIG_LINKS([t/defs:t/defs])
+AC_CONFIG_FILES([t/wrap/aclocal-${APIVERSION}:t/wrap/aclocal.in],
+ [chmod +x t/wrap/aclocal-${APIVERSION}],
[APIVERSION=$APIVERSION])
-AC_CONFIG_FILES([tests/wrap/automake-${APIVERSION}:tests/wrap/automake.in],
- [chmod +x tests/wrap/automake-${APIVERSION}],
+AC_CONFIG_FILES([t/wrap/automake-${APIVERSION}:t/wrap/automake.in],
+ [chmod +x t/wrap/automake-${APIVERSION}],
[APIVERSION=$APIVERSION])
AC_OUTPUT