summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2011-12-27 22:01:12 +0100
committerStefano Lattarini <stefano.lattarini@gmail.com>2011-12-27 22:01:12 +0100
commitf0645e2ddf6327fafdd072d1c30d15f48510e605 (patch)
tree17fb95764b3f2616001a2c5ed38a8ec187fa54c8 /configure.ac
parent1560265e1ca8d5c542d27a4143e1879379831e12 (diff)
parent77b2c71c376f45b51a0e41774ab0e3cdf8d17932 (diff)
downloadautomake-f0645e2ddf6327fafdd072d1c30d15f48510e605.tar.gz
Merge branch 'maint' into yacc-work
* maint: (34 commits) tests: drop unnecessary requirement in 'subpkg.test' gitlog-to-changelog: new auxiliary script, synced from gnulib docs: "aclocal --install -I /abs/dir" actually copies files docs: fix node names for automake and aclocal invocations gitignore: use only one .gitignore file, in the top-level directory tests: one more fixlet for gettext macros requirement tests: fix handling of gettext macros requirement tests: fix failure due to debugging code forgotten into a test tests: avoid spurious failure of libtool and gettext tests hacking: distribute it, and mention it in the ChangeLog regex: deprecate the obsolete macro AM_WITH_REGEX maint: distribute .xz tarballs, not .bz2 ones maint: better use of autoconf 2.68 features cosmetics: use proper m4 quoting in configure.ac include: avoid "deleted .am file" problem tests: better handling of gettext and libtool requirements fix: typos and grammaros in comments of the new test tests: report useful system information in 'test-suite.log' python: remove relics for Python 1.5 support configure: remove extraneous 'eval's from AM_RUN_LOG invocations ...
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac51
1 files changed, 39 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 4a4cc2a04..fa05a494f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,13 +17,11 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-AC_INIT([GNU Automake], [1.11], [bug-automake@gnu.org])
+AC_PREREQ([2.68])
+AC_INIT([GNU Automake], [1.11.0a], [bug-automake@gnu.org])
-m4_ifndef([AC_PACKAGE_URL],
- [AC_SUBST([PACKAGE_URL], [http://www.gnu.org/software/automake/])])
-
-AC_CONFIG_SRCDIR(automake.in)
-AC_CONFIG_AUX_DIR(lib)
+AC_CONFIG_SRCDIR([automake.in])
+AC_CONFIG_AUX_DIR([lib])
AC_CANONICAL_BUILD
@@ -37,7 +35,7 @@ AC_SUBST([am_AUTORECONF], ["${AUTORECONF-autoreconf}"])
AC_SUBST([am_AUTOHEADER], ["${AUTOHEADER-autoheader}"])
AC_SUBST([am_AUTOUPDATE], ["${AUTOUPDATE-autoupdate}"])
-AM_INIT_AUTOMAKE([1.10a dist-bzip2 filename-length-max=99 color-tests parallel-tests])
+AM_INIT_AUTOMAKE([1.10a dist-xz filename-length-max=99 color-tests parallel-tests])
# The API version is the base version. We must guarantee
# compatibility for all releases with the same API version.
@@ -57,12 +55,12 @@ AC_SUBST([pkgvdatadir], ["\${datadir}/$PACKAGE-$APIVERSION"])
ACLOCAL="perllibdir=\"`pwd`/lib$PATH_SEPARATOR./lib\" \"`pwd`/aclocal\" --acdir=m4 -I m4"
AUTOMAKE="perllibdir=\"`pwd`/lib$PATH_SEPARATOR./lib\" \"`pwd`/automake\" --libdir=lib"
-AC_PATH_PROG(PERL, perl)
+AC_PATH_PROG([PERL], [perl])
if test -z "$PERL"; then
AC_MSG_ERROR([perl not found])
fi
# Save details about the selected perl interpreter in config.log.
-AM_RUN_LOG([eval $PERL --version])
+AM_RUN_LOG([$PERL --version])
$PERL -e 'require 5.006;' || {
AC_MSG_ERROR(
[perl 5.6 or better is required; perl 5.8.2 or better
@@ -99,6 +97,10 @@ AC_SUBST([PERL_THREADS])
# The test suite will skip some tests if tex is absent.
AC_CHECK_PROG([TEX], [tex], [tex])
+# Save details about the selected TeX program in config.log.
+# Redirect input from /dev/null, as TeX might otherwise hang waiting
+# for input from the terminal.
+AM_RUN_LOG([$TEX --version </dev/null])
# The test suite will skip some tests if no lex or yacc program is
# available.
@@ -130,7 +132,7 @@ AM_MISSING_PROG([HELP2MAN], [help2man])
required_autoconf_version=2.62
AC_CACHE_CHECK([whether autoconf is installed], [am_cv_autoconf_installed],
-[if AM_RUN_LOG([eval $am_AUTOCONF --version]);
+[if AM_RUN_LOG([$am_AUTOCONF --version]);
then
am_cv_autoconf_installed=yes
else
@@ -144,7 +146,7 @@ fi
AC_CACHE_CHECK([whether autoconf works], [am_cv_autoconf_works],
[mkdir conftest
echo 'AC''_INIT' > conftest/conftest.ac
-if AM_RUN_LOG([cd conftest && eval $am_AUTOCONF -o /dev/null conftest.ac]);
+if AM_RUN_LOG([cd conftest && $am_AUTOCONF -o /dev/null conftest.ac]);
then
am_cv_autoconf_works=yes
else
@@ -160,7 +162,7 @@ AC_CACHE_CHECK([whether autoconf is recent enough], [am_cv_autoconf_version],
[mkdir conftest
dnl Creative quoting required to avoid spurious expansion of AC_PREREQ macro
echo 'AC'"_PREREQ([[$required_autoconf_version]])" > conftest/conftest.ac
-if AM_RUN_LOG([cd conftest && eval $am_AUTOCONF -o /dev/null conftest.ac]);
+if AM_RUN_LOG([cd conftest && $am_AUTOCONF -o /dev/null conftest.ac]);
then
am_cv_autoconf_version=yes
else
@@ -237,3 +239,28 @@ AC_CONFIG_FILES([tests/automake-${APIVERSION}:tests/automake.in],
[chmod +x tests/automake-${APIVERSION}])
AC_OUTPUT
+
+# Inform the user if this version of automake is a beta release or
+# a development snapshot.
+# According to HACKING, the version of a development snapshot should
+# end with an "odd" letter (a, c, ...), the version of a test release
+# should end wit an "even" letter (b, d, ...).
+
+am_stable_version_rx='[[1-9]\.[0-9]+(\.[0-9]+)?]'
+am_beta_version_rx="[$am_stable_version_rx[bdfhjlnprtvxz]]"
+
+am_release_type=`AS_ECHO(["$PACKAGE_VERSION"]) | LC_ALL=C awk ["
+ /^$am_stable_version_rx$/ { print \"stable\"; exit(0); }
+ /^$am_beta_version_rx$/ { print \"beta version\"; exit(0); }
+ { print \"development snapshot\"; }"]`
+
+test "$am_release_type" = stable || cat <<EOF
+
+WARNING: You are about to use a $am_release_type of automake.
+WARNING: It might easily suffer from new bugs or regressions.
+WARNING: You are strongly advised not to use it in production code.
+
+Please report bugs, problems and feedback to <bug-automake@gnu.org>.
+EOF
+
+AS_EXIT([0])