summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-07-16 11:16:15 +0200
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-07-16 11:16:15 +0200
commit094b83a641e3b5b4aedf8820cb2af9d1c32cb476 (patch)
treeb0f3e355941214e9a3325237690c6ba483e6008c /configure.ac
parent7eccbf44fcee432c20ccd95b384f1c3494e4712c (diff)
parent455437e864ee89f3e09b2d18a7215a79291925d1 (diff)
downloadautomake-094b83a641e3b5b4aedf8820cb2af9d1c32cb476.tar.gz
Merge branch 'maint'
* maint: fixup: delete "# serial" line in m4/amversion.in news: update about recent ylwrap changes and fixes m4: get rid of "# serial" lines configure: ${#param} must be supported by the shell for the testsuite yacc tests: fix a spurious failure with parallel make ylwrap: use proper quoting inside a `...` substitution ylwrap: don't uselessly reset the exit status in case of failure ylwrap: fix C++ support for Bison ylwrap: refactor: move loop invariant ylwrap: refactoring: don't rely on the file order tests: upgrade and fix Bison test case tests: fix bison input file ylwrap: comment changes ylwrap: modernize idioms ylwrap: rename header inclusion in generated parsers ylwrap: simplify the list of renamings ylwrap: refactor: less duplication Signed-off-by: Stefano Lattarini <stefano.lattarini@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bbaf12cde..69edd9a45 100644
--- a/configure.ac
+++ b/configure.ac
@@ -303,6 +303,14 @@ AC_DEFUN([_AM_CHECK_CANDIDATE_SHELL],
[], [am_score=1; break])
_AM_CHECK_SHELL_FEATURE([$1],
+ [supports \${@%:@var}],
+ [zero='' one='x' twelve=' foobar baz!' \
+ && test ${@%:@zero} -eq 0 \
+ && test ${@%:@one} -eq 1 \
+ && test ${@%:@twelve} -eq 12],
+ [], [am_score=1; break])
+
+ _AM_CHECK_SHELL_FEATURE([$1],
[supports \${var@%:@glob} and \${var%glob}],
[v=a/b/c \
&& test ${v@%:@*/} = b/c \