summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2011-12-28 13:23:31 +0100
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-05-07 21:38:47 +0200
commit21d1b9342743efdb196110093b3b6ee156688b83 (patch)
tree7aecfeadd08508428dbfa5729e5a6b5fb48b3ea3 /configure.ac
parentdda822736d5e66f5b8fa6888397894c09a5fdcaa (diff)
downloadautomake-21d1b9342743efdb196110093b3b6ee156688b83.tar.gz
tests: shell running test scripts is now named AM_TEST_RUNNER_SHELL
This is just a preparatory refactoring for future changes. * configure.ac (AM_TEST_RUNNER_SHELL): New variable, defined to $SHELL', and AC_SUBST'd. * Makefile.am (LOG_COMPILER): Redefine from $(SHELL) to $(AM_TEST_RUNNER_SHELL). * defs: Adjust to use $AM_TEST_RUNNER_SHELL instead of $CONFIG_SHELL and/or $SHELL, where appropriate. Minor opportunistic changes. * t/self-check-explicit-skips.sh: Likewise. * t/self-check-sanity.sh: Likewise. * t/self-check-tap.sh: Likewise. * t/self-check-cleanup.tap: Likewise. * t/self-check-dir.tap: Likewise. * t/self-check-env-sanitize.tap: Likewise. * t/self-check-exit.tap: Likewise. * t/self-check-me.tap: Likewise. * t/self-check-reexec.tap: Likewise. Signed-off-by: Stefano Lattarini <stefano.lattarini@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bda032863..8f3d40fba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -209,6 +209,10 @@ AC_SUBST([MODIFICATION_DELAY])
AC_PROG_EGREP
AC_PROG_FGREP
+# Shell used to run our test scripts. The same as $SHELL/$CONFIG_SHELL
+# for the moment.
+AC_SUBST([AM_TEST_RUNNER_SHELL], [$SHELL])
+
AC_CACHE_CHECK([whether $SHELL has working 'set -e' with exit trap],
[am_cv_sh_errexit_works],
[if $SHELL -ec "trap 'exit \$?' 0; (exit 77); exit 77"; test $? = 77