summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-01-16 10:05:59 +0100
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-01-16 10:11:00 +0100
commit27f1a1c967bc6af59cc940ba42114d795fb458d5 (patch)
tree29138ec6efe4ee731bb8059a51f802e10d4bbd6a /tests/Makefile.am
parent48c9d57f1769789dfd6cb876bd3e82d2252d1e59 (diff)
downloadautomake-27f1a1c967bc6af59cc940ba42114d795fb458d5.tar.gz
maintcheck: consistency of list of test scripts
This is basically a backport of commit 'v1.11-358-g7b6ab07' and its follow-ups. The possibility of easily checking that the list of test scripts listed in a Makefile equals that of the tests on the filesystem has proved itself so useful that it's worth taking the annoyance of backporting it to maint. * CheckListOfTests.am: New file, backported from master (commit 'v1.11-1736-g083a75b') with minor adjustments. (maintainer-check-list-of-tests): New target, check for consistency between the list of tests defined in the including Makefile and the list of tests on the filesystem. (clean-maintcheck-testslist-tmp): New rule, to clean up temporary files that might be left around by the rules associated with the previous target. (clean-local): Depend on it. * lib/Automake/tests/Makefile.am: Include `CheckListOfTests.am'. * tests/Makefile.am: Likewise. * Makefile.am (maintainer-check-list-of-test): New target, calling recursively into `tests/' and `lib/Automake/tests/', using ... (TEST_SUBDIRS): ... this new variable. (maintainer-check): Added dependency from the new target `maintainer-check-list-of-tests'.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b6f9fb320..c2daff4fb 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -127,6 +127,10 @@ EXTRA_DIST += distcheck-hook-m4.am
# Each test case depends on defs, aclocal, and automake.
check_SCRIPTS = defs aclocal-$(APIVERSION) automake-$(APIVERSION)
+## Checking the list of tests.
+include $(top_srcdir)/CheckListOfTests.am
+maintainer-check-list-of-tests: $(parallel_tests)
+
clean-local: clean-local-check
.PHONY: clean-local-check
clean-local-check: