summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index ae07898a7..83bcc7cea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,8 +3,8 @@
## Makefile for Automake.
# Copyright (C) 1995, 1996, 1997, 1998, 1999, 2001, 2002, 2003, 2004,
-# 2005, 2006, 2007, 2008, 2009, 2010, 2011 Free Software Foundation,
-# Inc.
+# 2005, 2006, 2007, 2008, 2009, 2010, 2011, 2012 Free Software
+# Foundation, Inc.
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -277,8 +277,8 @@ sc_diff_aclocal_in_aclocal:
## Syntax check with default Perl (on my machine, Perl 5).
sc_perl_syntax:
- perllibdir="./lib$(PATH_SEPARATOR)$(srcdir)/lib" $(PERL) -c -w automake
- perllibdir="./lib$(PATH_SEPARATOR)$(srcdir)/lib" $(PERL) -c -w aclocal
+ @perllibdir="./lib$(PATH_SEPARATOR)$(srcdir)/lib" $(PERL) -c -w automake
+ @perllibdir="./lib$(PATH_SEPARATOR)$(srcdir)/lib" $(PERL) -c -w aclocal
## expect no instances of '${...}'. However, $${...} is ok, since that
## is a shell construct, not a Makefile construct.
@@ -626,6 +626,7 @@ git-release: git-dist
--to $$dest.gnu.org:automake $(DIST_ARCHIVES)
git-diff:
+ $(AM_V_GEN):; \
thisver="v$(VERSION)"; \
if test -z "$$OLDVERSION"; then \
prevno=`echo "$(VERSION)" - 0.01 | bc | sed 's/^\./0./'`; \
@@ -636,7 +637,7 @@ git-diff:
## Check our path lengths.
path-check: distdir
- (cd $(distdir) && \
+ $(AM_V_GEN)($(am__cd) $(distdir) && \
## FIXME there's got to be a better way! pathchk should take the list
## of files on stdin, at least.
find . -print | xargs pathchk -p); \
@@ -767,7 +768,8 @@ fetch:
## This has to be run in an up to date build tree, but there must
## be no temp files nor unused other files lying around!
release-stats: ps
- @am=`wc -l < automake` && \
+ $(AM_V_GEN): && \
+ am=`wc -l < automake` && \
acl=`wc -l < aclocal` && \
pmfiles="lib/Automake/*.pm" && \
if test . != '$(srcdir)'; then pmfiles="$$pmfiles $(srcdir)/lib/Automake/*.pm"; \