summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am83
1 files changed, 0 insertions, 83 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8ebd31b4d..5cb478ea7 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -192,86 +192,3 @@ clean-local-check:
find "$$@" -type d ! -perm -700 -exec chmod u+rwx {} ';'; \
rm -rf "$$@"; \
fi;
-
-## Run the testsuite through the 'prove' utility. Mostly for maintainers,
-## and to find out possible incompatibilities between 'prove' and the
-## Automake own TAP driver.
-
-PROVE = prove
-AM_PROVEFLAGS = --timer
-AM_PROVECMD = \
- test -z "$$tests" || \
- { \
- $(AM_TESTS_ENVIRONMENT) $(TESTS_ENVIRONMENT) \
- $(PROVE) $(AM_PROVEFLAGS) -e $(srcdir)/ax/prove-runner $(PROVEFLAGS) \
- $$tests $(AM_TESTS_FD_REDIRECT); \
- }
-
-EXTRA_DIST += ax/prove-runner
-
-.PHONY: prove installprove
-prove installprove: $(TESTS) ax/prove-runner defs-static
- @exit_status=0; \
-## The testsuite can be run either using the automake build tree or
-## the already-installed automake package.
- case '$@' in \
- install*) am_running_installcheck=yes;; \
- *) am_running_installcheck=no;; \
- esac; \
- export am_running_installcheck; \
-## XXX Our poor-man way to handle inter-tests dependencies without the
-## XXX help of make. This is obviously fragile and doesn't scale,
-## XXX but for now it's good enough since we have only one possible
-## XXX inter-tests dependency at the moment.
- need_tap_common_setup=no; \
- lst=' $(TESTS) '; for t in $$lst; do \
- case ' $(on_tap_with_common_setup_TESTS) ' in \
- *" $$t "*) need_tap_common_setup=yes; break;; \
- esac; \
- done; \
-## For VPATH builds.
- if test $$need_tap_common_setup = yes; then \
- t=tap-common-setup.test; \
- if test -f ./$$t; then \
- tests=./$$t; \
- else \
- tests=$(srcdir)/$$t; \
- fi; \
-## Do not stop if there's a failure here, we want to run the following
-## tests anyway.
- echo "$@: running pre-requisite tests ..."; \
- $(AM_PROVECMD) || exits_status=$$?; \
- echo "$@: done. We'll shortly run the main testsuite."; \
- fi; \
-## Handle VPATH builds, and ensure that the tests have a properly
-## qualified path.
- tests=`\
- for t in $(TESTS); do \
-## XXX In next line, another hack for inter-tests dependencies: this
-## XXX can't run concurrently to the tests that use the data files it
-## XXX generates.
- case "$$need_tap_common_setup,/$$t" in \
- yes,*/tap-common-setup.test) continue;; \
- esac; \
- if test -f ./$$t; then \
- echo ./$$t; \
- else \
- echo $(srcdir)/$$t; \
- fi; \
- done`; \
-## Extra environment, mostly for use by 'prove-runner'.
-## XFAIL_TESTS gets normalized to play nicer with VPATH builds.
- XFAIL_TESTS=`\
- for t in $(XFAIL_TESTS); do \
- echo $$t; echo ./$$t; echo $(srcdir)/$$t; \
- done | LC_ALL=C sort | uniq`; \
- XFAIL_TESTS=`echo $$XFAIL_TESTS`; \
- TAP_RUNNER='$(TAP_LOG_COMPILE)' \
- TEST_RUNER='$(TEST_LOG_COMPILE)' \
- export XFAIL_TESTS TAP_RUNNER TEST_RUNNER; \
-## For consistency with the Automake testsuite harness, that exports
-## this unconditionally in the test scripts' environment.
- srcdir='$(srcdir)'; export srcdir; \
-## Here we go.
- $(AM_PROVECMD) || exit_status=$$?; \
- exit $$exit_status;