summaryrefslogtreecommitdiff
path: root/packaging.in/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'packaging.in/debian/rules')
-rwxr-xr-xpackaging.in/debian/rules21
1 files changed, 21 insertions, 0 deletions
diff --git a/packaging.in/debian/rules b/packaging.in/debian/rules
new file mode 100755
index 00000000..451f74aa
--- /dev/null
+++ b/packaging.in/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
+# in template file --AC
+#%:
+# dh $@
+
+#all the rest copied from trip0's libobd debian/rules file --AC
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+
+DEB_CMAKE_NORMAL_ARGS += -Dbluemonkey_plugin=ON -Dbluetooth_plugin=ON -Dqtmainloop=ON
+DEB_BUILD_OPTIONS += parallel=8