summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..dbd137c
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,23 @@
+[tool.ruff]
+target-version = "py37"
+select = [
+ "B",
+ "C",
+ "E",
+ "F",
+ "I",
+ "SIM300",
+ "UP",
+]
+ignore = [
+ "C901", # Complexity
+ "E501", # Line length
+ "E731", # Do not assign a lambda expression (we use them on purpose)
+ "E741", # Ambiguous variable name
+ "UP012", # "utf-8" is on purpose
+]
+extend-exclude = [
+ "tests/messages/data",
+]
+[tool.ruff.per-file-ignores]
+"scripts/import_cldr.py" = ["E402"]