summaryrefslogtreecommitdiff
path: root/completions/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'completions/Makefile.am')
-rw-r--r--completions/Makefile.am137
1 files changed, 117 insertions, 20 deletions
diff --git a/completions/Makefile.am b/completions/Makefile.am
index e442a9e6..94cca466 100644
--- a/completions/Makefile.am
+++ b/completions/Makefile.am
@@ -5,7 +5,7 @@ bashcomp_DATA = 2to3 \
abook \
aclocal \
acpi \
- adb \
+ _adb \
add_members \
alias \
ant \
@@ -16,6 +16,7 @@ bashcomp_DATA = 2to3 \
apt-get \
aptitude \
arch \
+ arp \
arping \
arpspoof \
asciidoc \
@@ -48,8 +49,10 @@ bashcomp_DATA = 2to3 \
_chfn \
chgrp \
chkconfig \
+ chmod \
chown \
chpasswd \
+ chromium-browser \
chronyc \
chrpath \
_chsh \
@@ -76,6 +79,7 @@ bashcomp_DATA = 2to3 \
dhclient \
dict \
_dmesg \
+ dnssec-keygen \
dnsspoof \
dot \
dpkg \
@@ -87,6 +91,7 @@ bashcomp_DATA = 2to3 \
e2freefrag \
e2label \
ebtables \
+ ecryptfs-migrate-home \
_eject \
eog \
ether-wake \
@@ -103,9 +108,11 @@ bashcomp_DATA = 2to3 \
filesnarf \
find \
find_member \
+ fio \
+ firefox \
flake8 \
freebsd-update \
- freeciv-gtk2 \
+ freeciv \
freeciv-server \
function \
fusermount \
@@ -123,9 +130,11 @@ bashcomp_DATA = 2to3 \
gnatmake \
gnokii \
gnome-mplayer \
+ gnome-screenshot \
gpasswd \
gpg \
gpg2 \
+ gpgv \
gphoto2 \
gprof \
groupadd \
@@ -143,14 +152,17 @@ bashcomp_DATA = 2to3 \
hping2 \
htop \
htpasswd \
+ hunspell \
_hwclock \
iconv \
id \
idn \
+ ifstat \
iftop \
ifup \
info \
inject \
+ inotifywait \
insmod \
installpkg \
interdiff \
@@ -163,6 +175,7 @@ bashcomp_DATA = 2to3 \
iptables \
ipv6calc \
iscsiadm \
+ isort \
isql \
iwconfig \
iwlist \
@@ -172,9 +185,12 @@ bashcomp_DATA = 2to3 \
jarsigner \
java \
javaws \
+ jq \
jpegoptim \
jps \
jshint \
+ json_xs \
+ jsonschema \
k3b \
kcov \
kill \
@@ -198,6 +214,7 @@ bashcomp_DATA = 2to3 \
list_members \
list_owners \
_look \
+ locale-gen \
lpq \
lpr \
lrzip \
@@ -234,8 +251,8 @@ bashcomp_DATA = 2to3 \
modprobe \
_modules \
monodevelop \
- mount \
- mount.linux \
+ _mount \
+ _mount.linux \
mplayer \
mr \
msynctool \
@@ -246,6 +263,7 @@ bashcomp_DATA = 2to3 \
munin-update \
mussh \
mutt \
+ mypy \
mysql \
mysqladmin \
nc \
@@ -259,8 +277,10 @@ bashcomp_DATA = 2to3 \
_nmcli \
nproc \
nslookup \
+ nsupdate \
ntpdate \
oggdec \
+ op \
openssl \
opera \
optipng \
@@ -270,6 +290,7 @@ bashcomp_DATA = 2to3 \
patch \
pdftotext \
perl \
+ perlcritic \
perltidy \
pgrep \
pidof \
@@ -305,11 +326,12 @@ bashcomp_DATA = 2to3 \
pwd \
pwdx \
pwgen \
- py.test \
pycodestyle \
pydoc \
+ pydocstyle \
pyflakes \
pylint \
+ pytest \
python \
pyvenv \
qdbus \
@@ -343,7 +365,9 @@ bashcomp_DATA = 2to3 \
sbcl \
sbopkg \
screen \
+ scrub \
sh \
+ shellcheck \
sitecopy \
slackpkg \
slapt-get \
@@ -384,8 +408,9 @@ bashcomp_DATA = 2to3 \
tshark \
tune2fs \
_udevadm \
- umount \
- umount.linux \
+ ulimit \
+ _umount \
+ _umount.linux \
unace \
unpack200 \
unrar \
@@ -418,7 +443,7 @@ bashcomp_DATA = 2to3 \
xfreerdp \
xgamma \
xhost \
- xm \
+ _xm \
xmllint \
xmlwf \
xmms \
@@ -445,6 +470,7 @@ CLEANFILES = \
aclocal-1.13 \
aclocal-1.14 \
aclocal-1.15 \
+ aclocal-1.16 \
alpine \
alternatives \
animate \
@@ -459,6 +485,7 @@ CLEANFILES = \
automake-1.13 \
automake-1.14 \
automake-1.15 \
+ automake-1.16 \
autossh \
autoupdate \
bsdtar \
@@ -467,6 +494,8 @@ CLEANFILES = \
c++ \
cc \
cdrecord \
+ chrome \
+ chromium \
ci \
ciptool \
civclient \
@@ -491,34 +520,61 @@ CLEANFILES = \
dropdb \
dropuser \
edquota \
+ etherwake \
f77 \
f95 \
filebucket \
+ freeciv-gtk2 \
+ freeciv-gtk3 \
freeciv-sdl \
freeciv-xaw \
g++ \
+ g++-5 \
+ g++-6 \
+ g++-7 \
+ g++-8 \
g4 \
g77 \
g95 \
+ gcc-5 \
+ gcc-6 \
+ gcc-7 \
+ gcc-8 \
+ gccgo \
+ gccgo-5 \
+ gccgo-6 \
+ gccgo-7 \
+ gccgo-8 \
gcj \
geoiplookup6 \
gfortran \
+ gfortran-5 \
+ gfortran-6 \
+ gfortran-7 \
+ gfortran-8 \
gkrellm2 \
gmake \
gmplayer \
gnumake \
+ google-chrome \
+ google-chrome-stable \
gpc \
+ gpgv2 \
hciattach \
hciconfig \
hd \
host \
hping \
hping3 \
+ iceweasel \
identify \
ifdown \
+ ifquery \
ifstatus \
import \
+ inotifywatch \
insmod.static \
+ iperf3 \
javac \
javadoc \
kplayer \
@@ -531,6 +587,7 @@ CLEANFILES = \
ldapmodrdn \
ldappasswd \
ldapwhoami \
+ links2 \
lintian-info \
lusermod \
lvchange \
@@ -552,6 +609,7 @@ CLEANFILES = \
mkisofs \
mogrify \
montage \
+ mozilla-firefox \
mplayer2 \
msgsnarf \
muttng \
@@ -587,6 +645,7 @@ CLEANFILES = \
pvs \
pvscan \
pxz \
+ py.test \
py.test-2 \
py.test-3 \
pydoc3 \
@@ -594,10 +653,15 @@ CLEANFILES = \
pylint-3 \
pypy \
pypy3 \
+ pytest-2 \
+ pytest-3 \
python2 \
python3 \
pyvenv-3.4 \
pyvenv-3.5 \
+ pyvenv-3.6 \
+ pyvenv-3.7 \
+ pyvenv-3.8 \
qemu-kvm \
qemu-system-i386 \
qemu-system-x86_64 \
@@ -666,7 +730,7 @@ symlinks: $(targetdir) $(DATA)
$(LN_S) 7z $(targetdir)/$$file ; \
done
for file in aclocal-1.10 aclocal-1.11 aclocal-1.12 aclocal-1.13 \
- aclocal-1.14 aclocal-1.15 ; do \
+ aclocal-1.14 aclocal-1.15 aclocal-1.16 ; do \
rm -f $(targetdir)/$$file && \
$(LN_S) aclocal $(targetdir)/$$file ; \
done
@@ -683,7 +747,7 @@ symlinks: $(targetdir) $(DATA)
$(LN_S) asciidoc $(targetdir)/$$file ; \
done
for file in automake-1.10 automake-1.11 automake-1.12 automake-1.13 \
- automake-1.14 automake-1.15 ; do \
+ automake-1.14 automake-1.15 automake-1.16 ; do \
rm -f $(targetdir)/$$file && \
$(LN_S) automake $(targetdir)/$$file ; \
done
@@ -711,6 +775,10 @@ symlinks: $(targetdir) $(DATA)
rm -f $(targetdir)/$$file && \
$(LN_S) cardctl $(targetdir)/$$file ; \
done
+ for file in google-chrome google-chrome-stable chromium chrome; do \
+ rm -f $(targetdir)/$$file && \
+ $(LN_S) chromium-browser $(targetdir)/$$file ; \
+ done
for file in compgen ; do \
rm -f $(targetdir)/$$file && \
$(LN_S) complete $(targetdir)/$$file ; \
@@ -732,13 +800,22 @@ symlinks: $(targetdir) $(DATA)
rm -f $(targetdir)/$$file && \
$(LN_S) dpkg $(targetdir)/$$file ; \
done
+ for file in etherwake ; do \
+ rm -f $(targetdir)/$$file && \
+ $(LN_S) ether-wake $(targetdir)/$$file ; \
+ done
for file in mailsnarf msgsnarf ; do \
rm -f $(targetdir)/$$file && \
$(LN_S) filesnarf $(targetdir)/$$file ; \
done
- for file in civclient freeciv-sdl freeciv-xaw ; do \
+ for file in iceweasel mozilla-firefox ; do \
rm -f $(targetdir)/$$file && \
- $(LN_S) freeciv-gtk2 $(targetdir)/$$file ; \
+ $(LN_S) firefox $(targetdir)/$$file ; \
+ done
+ for file in civclient freeciv-gtk2 freeciv-gtk3 freeciv-sdl \
+ freeciv-xaw ; do \
+ rm -f $(targetdir)/$$file && \
+ $(LN_S) freeciv $(targetdir)/$$file ; \
done
for file in civserver ; do \
rm -f $(targetdir)/$$file && \
@@ -748,7 +825,10 @@ symlinks: $(targetdir) $(DATA)
rm -f $(targetdir)/$$file && \
$(LN_S) function $(targetdir)/$$file ; \
done
- for file in cc c++ g++ gfortran f77 g77 f95 g95 gcj gpc ; do \
+ for file in cc c++ g++ g++-5 g++-6 g++-7 g++-8 gfortran gfortran-5 \
+ gfortran-6 gfortran-7 gfortran-8 f77 g77 f95 g95 gcj gpc \
+ gccgo gccgo-5 gccgo-6 gccgo-7 gccgo-8 gcc-5 gcc-6 gcc-7 \
+ gcc-8 ; do \
rm -f $(targetdir)/$$file && \
$(LN_S) gcc $(targetdir)/$$file ; \
done
@@ -764,6 +844,10 @@ symlinks: $(targetdir) $(DATA)
rm -f $(targetdir)/$$file && \
$(LN_S) gkrellm $(targetdir)/$$file ; \
done
+ for file in gpgv2 ; do \
+ rm -f $(targetdir)/$$file && \
+ $(LN_S) gpgv $(targetdir)/$$file ; \
+ done
for file in pigz ; do \
rm -f $(targetdir)/$$file && \
$(LN_S) gzip $(targetdir)/$$file ; \
@@ -781,7 +865,7 @@ symlinks: $(targetdir) $(DATA)
rm -f $(targetdir)/$$file && \
$(LN_S) hping2 $(targetdir)/$$file ; \
done
- for file in ifdown ifstatus ; do \
+ for file in ifdown ifquery ifstatus ; do \
rm -f $(targetdir)/$$file && \
$(LN_S) ifup $(targetdir)/$$file ; \
done
@@ -789,10 +873,18 @@ symlinks: $(targetdir) $(DATA)
rm -f $(targetdir)/$$file && \
$(LN_S) info $(targetdir)/$$file ; \
done
+ for file in inotifywatch ; do \
+ rm -f $(targetdir)/$$file && \
+ $(LN_S) inotifywait $(targetdir)/$$file ; \
+ done
for file in insmod.static ; do \
rm -f $(targetdir)/$$file && \
$(LN_S) insmod $(targetdir)/$$file ; \
done
+ for file in iperf3 ; do \
+ rm -f $(targetdir)/$$file && \
+ $(LN_S) iperf $(targetdir)/$$file ; \
+ done
for file in javac javadoc ; do \
rm -f $(targetdir)/$$file && \
$(LN_S) java $(targetdir)/$$file ; \
@@ -806,6 +898,10 @@ symlinks: $(targetdir) $(DATA)
rm -f $(targetdir)/$$file && \
$(LN_S) ldapsearch $(targetdir)/$$file ; \
done
+ for file in links2 ; do \
+ rm -f $(targetdir)/$$file && \
+ $(LN_S) links $(targetdir)/$$file ; \
+ done
for file in lintian-info ; do \
rm -f $(targetdir)/$$file && \
$(LN_S) lintian $(targetdir)/$$file ; \
@@ -900,9 +996,9 @@ symlinks: $(targetdir) $(DATA)
rm -f $(targetdir)/$$file && \
$(LN_S) puppet $(targetdir)/$$file ; \
done
- for file in py.test-2 py.test-3 ; do \
+ for file in pytest-2 pytest-3 py.test py.test-2 py.test-3 ; do \
rm -f $(targetdir)/$$file && \
- $(LN_S) py.test $(targetdir)/$$file ; \
+ $(LN_S) pytest $(targetdir)/$$file ; \
done
for file in pydoc3 ; do \
rm -f $(targetdir)/$$file && \
@@ -916,7 +1012,8 @@ symlinks: $(targetdir) $(DATA)
rm -f $(targetdir)/$$file && \
$(LN_S) python $(targetdir)/$$file ; \
done
- for file in pyvenv-3.4 pyvenv-3.5 ; do \
+ for file in pyvenv-3.4 pyvenv-3.5 pyvenv-3.6 pyvenv-3.7 \
+ pyvenv-3.8 ; do \
rm -f $(targetdir)/$$file && \
$(LN_S) pyvenv $(targetdir)/$$file ; \
done
@@ -993,13 +1090,13 @@ symlinks: $(targetdir) $(DATA)
all-local: targetdir = .
all-local: symlinks
-install-data-local: targetdir = $(DESTDIR)$(bashcompdir)
-install-data-local: symlinks
+install-data-hook: targetdir = $(DESTDIR)$(bashcompdir)
+install-data-hook: symlinks
check-local:
ret=0
for file in $(bashcomp_DATA) ; do \
$${bashcomp_bash:-$${BASH:-bash}} \
- -O extglob -n $$file || ret=$$? ; \
+ -O extglob -n $(srcdir)/$$file || ret=$$? ; \
done ; \
exit $$ret