summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/extra/debhelper/dh_bash-completion2
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index d25c6fe4..1e4483be 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,8 @@
bash-completion (1:2.11-3) UNRELEASED; urgency=medium
+ [ Kevin Locke ]
+ * Improve file matching in dh_bash-completion (Closes: #985151).
+
-- Gabriel F. T. Gomes <gabriel@debian.org> Sat, 27 Mar 2021 17:39:56 -0300
bash-completion (1:2.11-2) unstable; urgency=medium
diff --git a/debian/extra/debhelper/dh_bash-completion b/debian/extra/debhelper/dh_bash-completion
index d1d9bf2e..7999151c 100755
--- a/debian/extra/debhelper/dh_bash-completion
+++ b/debian/extra/debhelper/dh_bash-completion
@@ -75,7 +75,7 @@ sub is_filelist {
#
# - If we see an "if...then" construction in the file. We
# take into account multi-line statements.
- if (/\s*complete.*-[A-Za-z].*/
+ if (/(^|[|&;])\s*complete.*-[A-Za-z].*/
|| /\$\(.*\)/
|| /\s*compgen.*-[A-Za-z].*/
|| /\s*if.*;.*then/s) {