summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorChet Ramey <chet.ramey@case.edu>2011-12-07 09:30:57 -0500
committerChet Ramey <chet.ramey@case.edu>2011-12-07 09:30:57 -0500
commit36211029b1dbdf292124a69ee7241ffe308062dd (patch)
treea3bee0202443fc61d968bcd2b2214653d9cc5cf8 /configure.in
parentf2f9854dfd1a35d3b2b10d5b59b96e951a45c3fe (diff)
downloadbash-36211029b1dbdf292124a69ee7241ffe308062dd.tar.gz
commit bash-20081023 snapshot
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index eb66b53c..fcbe3816 100644
--- a/configure.in
+++ b/configure.in
@@ -21,7 +21,7 @@ dnl Process this file with autoconf to produce a configure script.
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-AC_REVISION([for Bash 4.0, version 4.005])dnl
+AC_REVISION([for Bash 4.0, version 4.006])dnl
define(bashvers, 4.0)
define(relstatus, alpha)
@@ -989,7 +989,7 @@ dnl like glob and readline
LOCAL_DEFS=-DSHELL
dnl use this section to possibly define more cpp variables, specify local
-dnl libraries, and specify any additional local cc flags
+dnl libraries, and specify any additional local cc or ld flags
dnl
dnl this should really go away someday
@@ -1009,6 +1009,9 @@ sco3.2v4*) LOCAL_CFLAGS="-DMUST_UNBLOCK_CHLD -DPATH_MAX=1024" ;;
sco3.2*) LOCAL_CFLAGS=-DMUST_UNBLOCK_CHLD ;;
sunos4*) LOCAL_CFLAGS=-DSunOS4 ;;
solaris2.5*) LOCAL_CFLAGS="-DSunOS5 -DSOLARIS" ;;
+solaris2.8*) LOCAL_CFLAGS=-DSOLARIS LOCAL_LDFLAGS='-z interpose' ;;
+solaris2.9*) LOCAL_CFLAGS=-DSOLARIS LOCAL_LDFLAGS='-z interpose' ;;
+solaris2.10*) LOCAL_CFLAGS=-DSOLARIS LOCAL_LDFLAGS='-z interpose' ;;
solaris2*) LOCAL_CFLAGS=-DSOLARIS ;;
lynxos*) LOCAL_CFLAGS=-DRECYCLES_PIDS ;;
linux*) LOCAL_LDFLAGS=-rdynamic # allow dynamic loading