summaryrefslogtreecommitdiff
path: root/bc/Makefile.am
diff options
context:
space:
mode:
authorLars Wirzenius <lars.wirzenius@codethink.co.uk>2013-09-23 13:15:29 +0000
committerLars Wirzenius <lars.wirzenius@codethink.co.uk>2013-09-23 13:15:29 +0000
commit0956d119432ff6a2e85bae1fa336df799cad70b0 (patch)
tree7ab1b1b6d5c5bd7effdad00cbf20114b9e0f2aaf /bc/Makefile.am
parent5439ab7459283bf61a0256c3a20df164c780ef6c (diff)
parentd30971a0f40d716b644eecbd1d874742d84d57fd (diff)
downloadbc-tarball-baserock/morph.tar.gz
Merge branch 'baserock/liw/S8700-bc-segfault' into baserock/morphbaserock/morph
Reviewed-by: Jonathan Maw Reviewed-by: Richard Maw
Diffstat (limited to 'bc/Makefile.am')
-rw-r--r--bc/Makefile.am20
1 files changed, 13 insertions, 7 deletions
diff --git a/bc/Makefile.am b/bc/Makefile.am
index 9187339..409e342 100644
--- a/bc/Makefile.am
+++ b/bc/Makefile.am
@@ -1,7 +1,8 @@
## Process this file with automake to produce Makefile.in
bin_PROGRAMS = bc
-bc_SOURCES = main.c bc.y scan.l execute.c load.c storage.c util.c global.c
+bc_SOURCES = main.c bc.y scan.l execute.c load.c storage.c util.c global.c \
+ warranty.c
EXTRA_DIST = bc.h bcdefs.h const.h fix-libmath_h global.h libmath.b proto.h \
sbc.y
@@ -9,16 +10,19 @@ noinst_HEADERS = libmath.h
DISTCLEANFILES = sbc sbc.c sbc.h
-MAINTAINERCLEANFILES = Makefile.in libmath.h bc.c bc.h scan.c
+MAINTAINERCLEANFILES = Makefile.in libmath.h bc.c bc.h scan.c \
+ bc.y bcdefs.h const.h execute.c fix-libmath_h \
+ global.c global.h libmath.b load.c main.c \
+ proto.h scan.l storage.c util.c
INCLUDES = -I$(srcdir) -I$(srcdir)/../h
LIBBC = ../lib/libbc.a
LIBL = @LEXLIB@
LDADD = $(LIBBC) $(LIBL) @READLINELIB@
-YFLAGS = -d
+AM_YFLAGS = -d
-CFLAGS = @CFLAGS@ -Wall -funsigned-char
+AM_CFLAGS = @CFLAGS@
$(PROGRAMS): $(LIBBC)
@@ -30,13 +34,15 @@ libmath.h: libmath.b
$(MAKE) fbc
./fbc -c $(srcdir)/libmath.b </dev/null >libmath.h
$(srcdir)/fix-libmath_h
- rm -f ./fbc
+ rm -f ./fbc ./global.o
-fbcOBJ = main.o bc.o scan.o execute.o global.o load.o storage.o util.o
+fbcOBJ = main.o bc.o scan.o execute.o global.o load.o storage.o util.o \
+ warranty.o
fbc: $(fbcOBJ)
$(LINK) $(fbcOBJ) $(LIBBC) $(LIBL) $(READLINELIB) $(LIBS)
-sbcOBJ = main.o sbc.o scan.o execute.o global.o load.o storage.o util.o
+sbcOBJ = main.o sbc.o scan.o execute.o global.o load.o storage.o util.o \
+ warranty.o
sbc.o: sbc.c
sbc: $(sbcOBJ)
$(LINK) $(sbcOBJ) $(LIBBC) $(LIBL) $(READLINELIB) $(LIBS)