summaryrefslogtreecommitdiff
path: root/bc/Makefile.am
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@baserock.org>2000-11-15 20:19:18 +0000
committer <>2013-04-02 19:12:58 +0000
commit5439ab7459283bf61a0256c3a20df164c780ef6c (patch)
treeb44434fc37619db54e956a868b9d99972357d0d4 /bc/Makefile.am
downloadbc-tarball-5439ab7459283bf61a0256c3a20df164c780ef6c.tar.gz
Imported from /home/lorry/working-area/delta_bc-tarball/bc-1.06.tar.gz.bc-1.06
Diffstat (limited to 'bc/Makefile.am')
-rw-r--r--bc/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/bc/Makefile.am b/bc/Makefile.am
new file mode 100644
index 0000000..9187339
--- /dev/null
+++ b/bc/Makefile.am
@@ -0,0 +1,42 @@
+## Process this file with automake to produce Makefile.in
+bin_PROGRAMS = bc
+
+bc_SOURCES = main.c bc.y scan.l execute.c load.c storage.c util.c global.c
+
+EXTRA_DIST = bc.h bcdefs.h const.h fix-libmath_h global.h libmath.b proto.h \
+ sbc.y
+noinst_HEADERS = libmath.h
+
+DISTCLEANFILES = sbc sbc.c sbc.h
+
+MAINTAINERCLEANFILES = Makefile.in libmath.h bc.c bc.h scan.c
+
+INCLUDES = -I$(srcdir) -I$(srcdir)/../h
+LIBBC = ../lib/libbc.a
+LIBL = @LEXLIB@
+LDADD = $(LIBBC) $(LIBL) @READLINELIB@
+
+YFLAGS = -d
+
+CFLAGS = @CFLAGS@ -Wall -funsigned-char
+
+$(PROGRAMS): $(LIBBC)
+
+scan.o: bc.h
+global.o: libmath.h
+
+libmath.h: libmath.b
+ echo '{0}' > libmath.h
+ $(MAKE) fbc
+ ./fbc -c $(srcdir)/libmath.b </dev/null >libmath.h
+ $(srcdir)/fix-libmath_h
+ rm -f ./fbc
+
+fbcOBJ = main.o bc.o scan.o execute.o global.o load.o storage.o util.o
+fbc: $(fbcOBJ)
+ $(LINK) $(fbcOBJ) $(LIBBC) $(LIBL) $(READLINELIB) $(LIBS)
+
+sbcOBJ = main.o sbc.o scan.o execute.o global.o load.o storage.o util.o
+sbc.o: sbc.c
+sbc: $(sbcOBJ)
+ $(LINK) $(sbcOBJ) $(LIBBC) $(LIBL) $(READLINELIB) $(LIBS)