summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2021-06-10 12:47:14 +0300
committerIvan Maidanski <ivmai@mail.ru>2021-06-10 12:48:48 +0300
commit6668de8af9c779e927c3437c841ecb11a9adf492 (patch)
tree845efa850366a8cef92dec2b84017defc46dd89c /CMakeLists.txt
parentf4172eaf26489069060d1970e8d389f01f41baca (diff)
downloadbdwgc-6668de8af9c779e927c3437c841ecb11a9adf492.tar.gz
Fix missing specific.c in CMake script
* CMakeLists.txt [CMAKE_USE_PTHREADS_INIT && enable_thread_local_alloc] (SRC): Add specific.c file.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 56ed4814..d370433b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -134,7 +134,7 @@ if (CMAKE_USE_PTHREADS_INIT)
endif()
if (enable_thread_local_alloc)
add_definitions("-DTHREAD_LOCAL_ALLOC")
- set(SRC ${SRC} thread_local_alloc.c)
+ set(SRC ${SRC} specific.c thread_local_alloc.c)
endif()
message("Explicit GC_INIT() calls may be required.")
if (HOST MATCHES .*-.*-hpux11.*)