summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 0d2b3853..5425fb43 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -70,22 +70,24 @@ libgc_la_SOURCES = \
# C Library: Architecture Dependent
# ---------------------------------
+if THREADS
+
+libgc_la_SOURCES += pthread_start.c pthread_support.c
+
+if THREAD_LOCAL_ALLOC
+libgc_la_SOURCES += thread_local_alloc.c
+endif
+
if WIN32_THREADS
libgc_la_SOURCES += win32_threads.c
else
-if PTHREADS
-# Not Cygwin or MinGW.
-libgc_la_SOURCES += pthread_start.c pthread_support.c
if DARWIN_THREADS
libgc_la_SOURCES += darwin_stop_world.c
else
libgc_la_SOURCES += pthread_stop_world.c
endif
endif
-endif
-if THREAD_LOCAL_ALLOC
-libgc_la_SOURCES += thread_local_alloc.c
endif
if MAKE_BACK_GRAPH