summaryrefslogtreecommitdiff
path: root/ld/configure.in
diff options
context:
space:
mode:
authorRichard Sandiford <rdsandiford@googlemail.com>2007-05-16 07:19:46 +0000
committerRichard Sandiford <rdsandiford@googlemail.com>2007-05-16 07:19:46 +0000
commitfa1e8d8e04abc3c79eb2597a34ca7e57a27ecd42 (patch)
tree2c2cb16fad40ddff13d82cae21775564a3bdbe19 /ld/configure.in
parent017f71b6e8e47aa87ed6e08c6e19c4aa50466888 (diff)
downloadbinutils-gdb-fa1e8d8e04abc3c79eb2597a34ca7e57a27ecd42.tar.gz
ld/
* configure.in: Allow sysroots to be relocated under $prefix as well as $exec_prefix. * configure: Regenerate.
Diffstat (limited to 'ld/configure.in')
-rw-r--r--ld/configure.in15
1 files changed, 9 insertions, 6 deletions
diff --git a/ld/configure.in b/ld/configure.in
index 3fd64c068f2..0589578a74a 100644
--- a/ld/configure.in
+++ b/ld/configure.in
@@ -41,17 +41,20 @@ AC_ARG_WITH(sysroot,
TARGET_SYSTEM_ROOT_DEFINE='-DTARGET_SYSTEM_ROOT=\"$(TARGET_SYSTEM_ROOT)\"'
use_sysroot=yes
+ if test "x$prefix" = xNONE; then
+ test_prefix=/usr/local
+ else
+ test_prefix=$prefix
+ fi
if test "x$exec_prefix" = xNONE; then
- if test "x$prefix" = xNONE; then
- test_prefix=/usr/local
- else
- test_prefix=$prefix
- fi
+ test_exec_prefix=$test_prefix
else
- test_prefix=$exec_prefix
+ test_exec_prefix=$exec_prefix
fi
case ${TARGET_SYSTEM_ROOT} in
"${test_prefix}"|"${test_prefix}/"*|\
+ "${test_exec_prefix}"|"${test_exec_prefix}/"*|\
+ '${prefix}'|'${prefix}/'*|\
'${exec_prefix}'|'${exec_prefix}/'*)
t="$TARGET_SYSTEM_ROOT_DEFINE -DTARGET_SYSTEM_ROOT_RELOCATABLE"
TARGET_SYSTEM_ROOT_DEFINE="$t"