summaryrefslogtreecommitdiff
path: root/bfd/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'bfd/configure.in')
-rw-r--r--bfd/configure.in22
1 files changed, 21 insertions, 1 deletions
diff --git a/bfd/configure.in b/bfd/configure.in
index 081fe083765..d71f45f2ada 100644
--- a/bfd/configure.in
+++ b/bfd/configure.in
@@ -8,6 +8,26 @@ AC_CANONICAL_SYSTEM
AC_ISC_POSIX
AM_INIT_AUTOMAKE(bfd, 2.11.92)
+# Uncomment the next line to remove the date from the reported bfd version
+#is_release=y
+
+changequote(,)dnl
+bfd_version=`echo "${VERSION}" | sed -e 's/\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\).*/\1.00\2.00\3.00\4.00\5/' -e 's/\([^\.]*\)\..*\(..\)\..*\(..\)\..*\(..\)\..*\(..\)$/\1\2\3\4\5/'`
+changequote([,])dnl
+
+bfd_version_string="\"${VERSION}\""
+bfd_version_date=`sed -e 's/.*DATE //' < ${srcdir}/version.h`
+if test x${is_release} = x; then
+dnl Sad, but we can't use XSTRING here to pick up the date from version.h
+dnl because traditional C doesn't allow it.
+ bfd_version_string="\"${VERSION} ${bfd_version_date}\""
+fi
+dnl Since we need to edit bfd-in3.h to get the date for bfd_version_string,
+dnl we may as well substitute for bfd_version_date too. That way we don't
+dnl need to #include version.h
+AC_SUBST(bfd_version)
+AC_SUBST(bfd_version_date)
+AC_SUBST(bfd_version_string)
dnl These must be called before AM_PROG_LIBTOOL, because it may want
dnl to call AC_CHECK_PROG.
@@ -751,6 +771,6 @@ case ${want_mmap}+${ac_cv_func_mmap_fixed_mapped} in
esac
rm -f doc/config.status
-AC_OUTPUT(Makefile doc/Makefile bfd-in3.h:bfd-in2.h po/Makefile.in:po/Make-in,
+AC_OUTPUT(Makefile doc/Makefile bfd-in3.h:bfd-in2.h:version.h po/Makefile.in:po/Make-in,
[sed -e '/SRC-POTFILES =/r po/SRC-POTFILES' -e '/BLD-POTFILES =/r po/BLD-POTFILES' po/Makefile.in > po/Makefile])