summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index 2725e1868a0..906aa70fd38 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -33,6 +33,9 @@ AC_AIX
AC_ISC_POSIX
AM_PROG_CC_STDC
+dnl The SHA-1 implementation needs to know the host endianness.
+AC_C_BIGENDIAN
+
AC_CONFIG_AUX_DIR(`cd $srcdir;pwd`/..)
AC_CANONICAL_SYSTEM
@@ -422,6 +425,9 @@ AC_CHECK_HEADERS(term.h, [], [],
# unconditionally, so what's the point in checking these?
AC_CHECK_HEADERS(ctype.h time.h)
+# Create a header we can use portably to get the standard integer types.
+GCC_HEADER_STDINT(gdb_stdint.h)
+
# ------------------------- #
# Checks for declarations. #
# ------------------------- #