summaryrefslogtreecommitdiff
path: root/gdb/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'gdb/configure.in')
-rw-r--r--gdb/configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/gdb/configure.in b/gdb/configure.in
index 1046d2e6234..e85f6367a84 100644
--- a/gdb/configure.in
+++ b/gdb/configure.in
@@ -41,6 +41,7 @@ dnl List of object files added by configure.
CONFIG_OBS=
CONFIG_DEPS=
CONFIG_SRCS=
+CONFIG_INIT=
configdirs="doc testsuite"
@@ -305,6 +306,7 @@ if test ${build} = ${host} -a ${host} = ${target} ; then
AC_DEFINE(HAVE_HPUX_THREAD_SUPPORT)
CONFIG_OBS="${CONFIG_OJS} hpux-thread.o"
CONFIG_SRCS="${CONFIG_SRCS} hpux-thread.c"
+ CONFIG_INITS="${CONFIG_INITS} hpux-thread.c"
else
AC_MSG_RESULT(no (suppressed because you are not using GCC))
fi
@@ -319,6 +321,7 @@ if test ${build} = ${host} -a ${host} = ${target} ; then
AC_DEFINE(HAVE_THREAD_DB_LIB)
CONFIG_OBS="${CONFIG_OBS} sol-thread.o"
CONFIG_SRCS="${CONFIG_SRCS} sol-thread.c"
+ CONFIG_INITS="${CONFIG_INITS} sol-thread.c"
AC_CHECK_LIB(dl, dlopen)
if test "$GCC" = "yes" ; then
# The GNU linker requires the -export-dynamic option to make
@@ -395,6 +398,7 @@ esac])
if test "${enable_netrom}" = "yes"; then
CONFIG_OBS="${CONFIG_OBS} remote-nrom.o"
CONFIG_SRCS="${CONFIG_SRCS} remote-nrom.c"
+ CONFIG_INITS="${CONFIG_INITS} remote-nrom.c"
fi
AC_ARG_ENABLE(build-warnings,
@@ -574,6 +578,7 @@ AC_SUBST(ENABLE_CFLAGS)
AC_SUBST(CONFIG_OBS)
AC_SUBST(CONFIG_DEPS)
AC_SUBST(CONFIG_SRCS)
+AC_SUBST(CONFIG_INITS)
# Begin stuff to support --enable-shared
AC_ARG_ENABLE(shared,