summaryrefslogtreecommitdiff
path: root/gdbsupport/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gdbsupport/configure.ac')
-rw-r--r--gdbsupport/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/gdbsupport/configure.ac b/gdbsupport/configure.ac
index 4222bb76d5b..1f794605f3c 100644
--- a/gdbsupport/configure.ac
+++ b/gdbsupport/configure.ac
@@ -53,10 +53,14 @@ GDB_AC_COMMON
GDB_AC_SELFTEST
AM_CONDITIONAL(SELFTEST, $enable_unittests)
+AM_CONDITIONAL(HAVE_PIPE_OR_PIPE2,
+ [test x$ac_cv_func_pipe = xyes -o x$ac_cv_func_pipe2 = xyes ])
+
# Check the return and argument types of ptrace.
GDB_AC_PTRACE
# Detect support warning flags.
+AM_GDB_COMPILER_TYPE
AM_GDB_WARNINGS
case ${host} in