summaryrefslogtreecommitdiff
path: root/gprof/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'gprof/configure.in')
-rw-r--r--gprof/configure.in81
1 files changed, 0 insertions, 81 deletions
diff --git a/gprof/configure.in b/gprof/configure.in
deleted file mode 100644
index 7d6ca2cc25a..00000000000
--- a/gprof/configure.in
+++ /dev/null
@@ -1,81 +0,0 @@
-dnl Process this file with autoconf to produce a configure script.
-AC_PREREQ(2.13)
-AC_INIT(gprof.c)
-
-AC_CANONICAL_SYSTEM
-AC_ISC_POSIX
-
-changequote(,)dnl
-BFD_VERSION=`sed -n -e 's/^.._INIT_AUTOMAKE.*,[ ]*\([^ ]*\)[ ]*).*/\1/p' < ${srcdir}/../bfd/configure.in`
-changequote([,])dnl
-AM_INIT_AUTOMAKE(gprof, ${BFD_VERSION})
-
-AM_PROG_LIBTOOL
-
-dnl For simplicity, we use the BFD configuration file for most
-dnl things. However, we also need our own configuration file for
-dnl the automake PACKAGE and VERSION macros. We don't name it
-dnl config.h, to avoid any possible confusion with the bfd config.h.
-AM_CONFIG_HEADER(gconfig.h:gconfig.in)
-
-AC_PROG_CC
-AC_PROG_INSTALL
-
-AC_CHECK_FUNCS(setmode)
-
-ALL_LINGUAS=
-CY_GNU_GETTEXT
-
-AM_MAINTAINER_MODE
-AC_EXEEXT
-
-AC_CHECK_HEADERS(sys/gmon_out.h)
-
-AC_MSG_CHECKING(the size of gmon pointers)
-AC_TRY_RUN([#include <stdio.h>
-#include <stdlib.h>
-#if HAVE_SYS_GMON_OUT_H
-#include <sys/gmon_out.h>
-#endif
-main()
-{
-#if HAVE_SYS_GMON_OUT_H
- struct gmon_cg_arc_record arc;
- FILE *f=fopen("conftestval", "w");
- if (!f) exit(1);
- fprintf(f, "%d\n", sizeof(arc.from_pc));
- exit(0);
-#else
- FILE *f=fopen("conftestval", "w");
- if (!f) exit(1);
- fprintf(f, "%d\n", (int) sizeof(char *));
- exit(1);
-#endif
-}], gmon_ptr_size=`cat conftestval`, gmon_ptr_size=4, gmon_ptr_size=4)
-AC_MSG_RESULT($gmon_ptr_size)
-
-AC_DEFINE_UNQUOTED(GMON_PTR_SIZE, $gmon_ptr_size)
-
-build_warnings="-W -Wall"
-AC_ARG_ENABLE(build-warnings,
-[ --enable-build-warnings Enable build-time compiler warnings if gcc is used],
-[case "${enableval}" in
- yes) ;;
- no) build_warnings="-w";;
- ,*) t=`echo "${enableval}" | sed -e "s/,/ /g"`
- build_warnings="${build_warnings} ${t}";;
- *,) t=`echo "${enableval}" | sed -e "s/,/ /g"`
- build_warnings="${t} ${build_warnings}";;
- *) build_warnings=`echo "${enableval}" | sed -e "s/,/ /g"`;;
-esac
-if test x"$silent" != x"yes" && test x"$build_warnings" != x""; then
- echo "Setting warning flags = $build_warnings" 6>&1
-fi])dnl
-WARN_CFLAGS=""
-if test "x${build_warnings}" != x -a "x$GCC" = xyes ; then
- WARN_CFLAGS="${build_warnings}"
-fi
-AC_SUBST(WARN_CFLAGS)
-
-AC_OUTPUT(Makefile po/Makefile.in:po/Make-in,
-[sed -e '/POTFILES =/r po/POTFILES' po/Makefile.in > po/Makefile])