summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlexandre Oliva <aoliva@redhat.com>2000-09-02 07:24:51 +0000
committerAlexandre Oliva <aoliva@redhat.com>2000-09-02 07:24:51 +0000
commitf0973d2464aa2f083a7bdfa442633ba868573047 (patch)
treecfe1112d9e453ffd4d3e0bc9adfce9be40520dd0 /configure.in
parent3144817e7d7d21763b6edd08e3439649dbfefe84 (diff)
downloadbinutils-redhat-f0973d2464aa2f083a7bdfa442633ba868573047.tar.gz
* configure.in (FLAGS_FOR_TARGET): Use -nostdinc even for Canadian
crosses, but add gcc/include to the header search path for them.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 20 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 9af1fd16dd..8daa3f3bd9 100644
--- a/configure.in
+++ b/configure.in
@@ -1233,11 +1233,27 @@ case " $skipdirs " in
FLAGS_FOR_TARGET=$FLAGS_FOR_TARGET' -L$$r/$(TARGET_SUBDIR)/winsup -L$$r/$(TARGET_SUBDIR)/winsup/cygwin -L$$r/$(TARGET_SUBDIR)/winsup/w32api/lib -isystem $$s/winsup/include -isystem $$s/winsup/cygwin/include -isystem $$s/winsup/w32api/include -isystem $$s/newlib/libc/sys/cygwin -isystem $$s/newlib/libc/sys/cygwin32' ;;
esac
- # If we're using a pre-built compiler (which is the case for
- # Canadian crosses or when gcc isn't being built), don't discard
- # standard headers.
- if test "${build}" = "${host}" && test -d ${topsrcdir}/gcc; then
+ # If we're not building GCC, don't discard standard headers.
+ if test -d ${topsrcdir}/gcc; then
FLAGS_FOR_TARGET=$FLAGS_FOR_TARGET' -nostdinc'
+
+ if test "${build}" != "${host}"; then
+ # On Canadian crosses, CC_FOR_TARGET will have already been set
+ # by `configure', so we won't have an opportunity to add -Bgcc/
+ # to it. This is right: we don't want to search that directory
+ # for binaries, but we want the header files in there, so add
+ # them explicitly.
+ FLAGS_FOR_TARGET=$FLAGS_FOR_TARGET' -isystem $$r/gcc/include'
+
+ # Someone might think of using the pre-installed headers on
+ # Canadian crosses, in case the installed compiler is not fully
+ # compatible with the compiler being built. In this case, it
+ # would be better to flag an error than risking having
+ # incompatible object files being constructed. We can't
+ # guarantee that an error will be flagged, but let's hope the
+ # compiler will do it, when presented with incompatible header
+ # files.
+ fi
fi
# If we're building newlib, use its generic headers last, but search