summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMark Mitchell <mark@codesourcery.com>2005-07-27 18:00:57 +0000
committerMark Mitchell <mark@codesourcery.com>2005-07-27 18:00:57 +0000
commitc59148ba8e732377ade8cd16e819b37a2bfcf0fd (patch)
tree93c56c74662ad7e7f413201c4203cbc387931458 /configure.in
parent17a781cb3e80808a2539e010d9c81c99e1402211 (diff)
downloadbinutils-redhat-c59148ba8e732377ade8cd16e819b37a2bfcf0fd.tar.gz
* config/mt-gnu (CXXFLAGS): Include SYSROOT_CFLAGS_FOR_TARGET.
* Makefile.tpl (SYSROOT_CFLAGS_FOR_TARGET): New variable. (CFLAGS_FOR_TARGET): Use it. (CXXFLAGS_FOR_TARGET): Likewise. * Makefile.in: Regenerated. * configure.in (--with-build-sysroot): New option. * configure: Regenerated.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d7c006c129..f5877a708a 100644
--- a/configure.in
+++ b/configure.in
@@ -1405,6 +1405,15 @@ esac
copy_dirs=
+AC_ARG_WITH([build-sysroot],
+ [ --with-build-sysroot=sysroot
+ use sysroot as the system root during the build],
+ [if test x"$withval" != x ; then
+ SYSROOT_CFLAGS_FOR_TARGET="--sysroot=$withval"
+ fi],
+ [SYSROOT_CFLAGS_FOR_TARGET=])
+AC_SUBST(SYSROOT_CFLAGS_FOR_TARGET)
+
# Handle --with-headers=XXX. If the value is not "yes", the contents of
# the named directory are copied to $(tooldir)/sys-include.
if test x"${with_headers}" != x && test x"${with_headers}" != xno ; then