summaryrefslogtreecommitdiff
path: root/gold/configure.ac
diff options
context:
space:
mode:
authorIan Lance Taylor <ian@airs.com>2011-07-02 00:31:35 +0000
committerIan Lance Taylor <ian@airs.com>2011-07-02 00:31:35 +0000
commiteca8eeb3a3e058f62160940a1681f36f65fc7941 (patch)
tree28dfc0a9787c7382c9d8996993fd39b1831506b8 /gold/configure.ac
parent8a5326a55253f9dfb4b9ec8cc7b811a94b842a54 (diff)
downloadbinutils-redhat-eca8eeb3a3e058f62160940a1681f36f65fc7941.tar.gz
Correct last commit.
Diffstat (limited to 'gold/configure.ac')
-rw-r--r--gold/configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/gold/configure.ac b/gold/configure.ac
index 47120b45bb..949c8c3b10 100644
--- a/gold/configure.ac
+++ b/gold/configure.ac
@@ -265,11 +265,12 @@ dnl Test for whether static linking is supported. Some systems do not
dnl install static libraries. This only affects the set of tests that
dnl we run.
AC_CACHE_CHECK([whether static linking works], [gold_cv_lib_static],
-LDFLAGS_hold=$LDFLAGS
+[LDFLAGS_hold=$LDFLAGS
LDFLAGS="$LDFLAGS -static"
-[AC_LINK_IFELSE([
+AC_LINK_IFELSE([
AC_LANG_PROGRAM([[void f() { }]])],
-[gold_cv_lib_static=yes], [gold_cv_lib_static=no])])
+[gold_cv_lib_static=yes], [gold_cv_lib_static=no])
+LDFLAGS=$LDFLAGS_hold])
AM_CONDITIONAL(HAVE_STATIC, test "$gold_cv_lib_static" = "yes")
dnl Some architectures do not support taking pointers of functions