summaryrefslogtreecommitdiff
path: root/binutils/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'binutils/configure.in')
-rw-r--r--binutils/configure.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/binutils/configure.in b/binutils/configure.in
index aa10ce90e2..27a14866ad 100644
--- a/binutils/configure.in
+++ b/binutils/configure.in
@@ -25,6 +25,27 @@ AC_ARG_ENABLE(commonbfdlib,
*) AC_MSG_ERROR([bad value ${enableval} for BFD commonbfdlib option]) ;;
esac])dnl
+build_warnings="-W -Wall"
+AC_ARG_ENABLE(build-warnings,
+[ --enable-build-warnings Enable build-time compiler warnings if gcc is used],
+[case "${enableval}" in
+ yes) ;;
+ no) build_warnings="-w";;
+ ,*) t=`echo "${enableval}" | sed -e "s/,/ /g"`
+ build_warnings="${build_warnings} ${t}";;
+ *,) t=`echo "${enableval}" | sed -e "s/,/ /g"`
+ build_warnings="${t} ${build_warnings}";;
+ *) build_warnings=`echo "${enableval}" | sed -e "s/,/ /g"`;;
+esac
+if test x"$silent" != x"yes" && test x"$build_warnings" != x""; then
+ echo "Setting warning flags = $build_warnings" 6>&1
+fi])dnl
+WARN_CFLAGS=""
+if test "x${build_warnings}" != x -a "x$GCC" = xyes ; then
+ WARN_CFLAGS="${build_warnings}"
+fi
+AC_SUBST(WARN_CFLAGS)
+
AM_CONFIG_HEADER(config.h:config.in)
if test -z "$target" ; then