summaryrefslogtreecommitdiff
path: root/binutils/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'binutils/doc/Makefile.am')
-rw-r--r--binutils/doc/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/binutils/doc/Makefile.am b/binutils/doc/Makefile.am
index 3f79ad4066..fe50d21218 100644
--- a/binutils/doc/Makefile.am
+++ b/binutils/doc/Makefile.am
@@ -8,7 +8,7 @@ CONFIG=all
# Options to extract the man page from as.texinfo
MANCONF = -Dman
-TEXI2POD = perl $(top_srcdir)/../etc/texi2pod.pl
+TEXI2POD = perl $(top_srcdir)/../etc/texi2pod.pl $(AM_MAKEINFOFLAGS)
POD2MAN = pod2man --center="GNU Development Tools" \
--release="binutils-$(VERSION)" --section=1
@@ -34,12 +34,13 @@ info_TEXINFOS = binutils.texi
binutils_TEXINFOS = config.texi
binutils_TEXI = $(srcdir)/binutils.texi
+AM_MAKEINFOFLAGS = -I "$(srcdir)" -I "$(top_srcdir)/../libiberty"
+
config.texi: $(srcdir)/../../bfd/configure $(binutils_TEXI)
rm -f config.texi
eval `grep '^ *VERSION=' $(srcdir)/../../bfd/configure`; \
echo "@set VERSION $$VERSION" > $@
echo "@set UPDATED `date "+%B %Y"`" >> config.texi
- echo "@set top_srcdir $(top_srcdir)" >> config.texi
# Man page generation from texinfo
addr2line.1: $(binutils_TEXI)