summaryrefslogtreecommitdiff
path: root/gold/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gold/configure.ac')
-rw-r--r--gold/configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/gold/configure.ac b/gold/configure.ac
index 1b46f4a852..e49bf211e6 100644
--- a/gold/configure.ac
+++ b/gold/configure.ac
@@ -312,9 +312,13 @@ error
#endif
], [gold_cv_prog_gcc41=yes], [gold_cv_prog_gcc41=no])])
+save_CFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS -mcmodel=medium"
+AC_COMPILE_IFELSE([int i;], [have_mcmodel_medium=yes], [have_mcmodel_medium=no])
+CFLAGS="$save_CFLAGS"
dnl Whether we can test -mcmodel=medium.
AM_CONDITIONAL(MCMODEL_MEDIUM,
-[test "$target_cpu" = "x86_64" -a "$gold_cv_prog_gcc41" = "yes"])
+[test "$target_cpu" = "x86_64" -a "$have_mcmodel_medium" = "yes" -a "$gold_cv_prog_gcc41" = "yes"])
dnl Test for __thread support.
AC_CACHE_CHECK([for thread support], [gold_cv_c_thread],