summaryrefslogtreecommitdiff
path: root/gold/testsuite/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gold/testsuite/Makefile.am')
-rw-r--r--gold/testsuite/Makefile.am34
1 files changed, 17 insertions, 17 deletions
diff --git a/gold/testsuite/Makefile.am b/gold/testsuite/Makefile.am
index 41259a2471..0d40e3ff4d 100644
--- a/gold/testsuite/Makefile.am
+++ b/gold/testsuite/Makefile.am
@@ -1331,7 +1331,7 @@ justsyms_LDADD =
justsyms_2.o: justsyms_2.cc
$(CXXCOMPILE) -c -o $@ $<
justsyms_2r.o: justsyms_2.o gcctestdir/ld $(srcdir)/justsyms.t
- gcctestdir/ld -o $@ -r -Wl,-T,$(srcdir)/justsyms.t justsyms_2.o
+ gcctestdir/ld -o $@ -r -T $(srcdir)/justsyms.t justsyms_2.o
check_PROGRAMS += justsyms_exec
justsyms_exec_SOURCES = justsyms_exec.c
@@ -1364,7 +1364,7 @@ ver_matching_def.so: ver_matching_def_pic.o $(srcdir)/version_script.map gcctest
ver_matching_def_pic.o: ver_matching_def.cc
$(CXXCOMPILE) -O0 -c -fpic -o $@ $<
ver_matching_test.stdout: ver_matching_def.so
- $(TEST_OBJDUMP) -Wl,-T,ver_matching_def.so | $(TEST_CXXFILT) > ver_matching_test.stdout
+ $(TEST_OBJDUMP) -T ver_matching_def.so | $(TEST_CXXFILT) > ver_matching_test.stdout
check_PROGRAMS += script_test_3
check_SCRIPTS += script_test_3.sh
@@ -1446,7 +1446,7 @@ check_PROGRAMS += script_test_11
script_test_11: gcctestdir/ld script_test_11_r.o
$(LINK) -Bgcctestdir/ script_test_11_r.o
script_test_11_r.o: gcctestdir/ld $(srcdir)/script_test_11.t script_test_11.o
- gcctestdir/ld -r -o $@ -Wl,-T,$(srcdir)/script_test_11.t script_test_11.o
+ gcctestdir/ld -r -o $@ -T $(srcdir)/script_test_11.t script_test_11.o
script_test_11.o: script_test_11.c
$(COMPILE) -c -g -o $@ $<
@@ -2270,7 +2270,7 @@ MOSTLYCLEANFILES += script_test_10
script_test_10.o: script_test_10.s
$(TEST_AS) -o $@ $<
script_test_10: $(srcdir)/script_test_10.t script_test_10.o gcctestdir/ld
- gcctestdir/ld -o $@ script_test_10.o -Wl,-T,$(srcdir)/script_test_10.t
+ gcctestdir/ld -o $@ script_test_10.o -T $(srcdir)/script_test_10.t
script_test_10.stdout: script_test_10
$(TEST_READELF) -SW script_test_10 > $@
@@ -2380,7 +2380,7 @@ arm_bl_in_range.stdout: arm_bl_in_range
$(TEST_OBJDUMP) -D $< > $@
arm_bl_in_range: arm_bl_in_range.o ../ld-new
- ../ld-new -Wl,-T,$(srcdir)/arm_branch_range.t -o $@ $<
+ ../ld-new -T $(srcdir)/arm_branch_range.t -o $@ $<
arm_bl_in_range.o: arm_bl_in_range.s
$(TEST_AS) -o $@ $<
@@ -2389,7 +2389,7 @@ arm_bl_out_of_range.stdout: arm_bl_out_of_range
$(TEST_OBJDUMP) -S $< > $@
arm_bl_out_of_range: arm_bl_out_of_range.o ../ld-new
- ../ld-new -Wl,-T,$(srcdir)/arm_branch_range.t -o $@ $<
+ ../ld-new -T $(srcdir)/arm_branch_range.t -o $@ $<
arm_bl_out_of_range.o: arm_bl_out_of_range.s
$(TEST_AS) -o $@ $<
@@ -2398,7 +2398,7 @@ thumb_bl_in_range.stdout: thumb_bl_in_range
$(TEST_OBJDUMP) -D $< > $@
thumb_bl_in_range: thumb_bl_in_range.o ../ld-new
- ../ld-new --no-fix-arm1176 -Wl,-T,$(srcdir)/thumb_branch_range.t -o $@ $<
+ ../ld-new --no-fix-arm1176 -T $(srcdir)/thumb_branch_range.t -o $@ $<
thumb_bl_in_range.o: thumb_bl_in_range.s
$(TEST_AS) -o $@ -march=armv5te $<
@@ -2407,7 +2407,7 @@ thumb_bl_out_of_range.stdout: thumb_bl_out_of_range
$(TEST_OBJDUMP) -D $< > $@
thumb_bl_out_of_range: thumb_bl_out_of_range.o ../ld-new
- ../ld-new --no-fix-arm1176 -Wl,-T,$(srcdir)/thumb_branch_range.t -o $@ $<
+ ../ld-new --no-fix-arm1176 -T $(srcdir)/thumb_branch_range.t -o $@ $<
thumb_bl_out_of_range.o: thumb_bl_out_of_range.s
$(TEST_AS) -o $@ -march=armv5te $<
@@ -2416,7 +2416,7 @@ thumb2_bl_in_range.stdout: thumb2_bl_in_range
$(TEST_OBJDUMP) -D $< > $@
thumb2_bl_in_range: thumb2_bl_in_range.o ../ld-new
- ../ld-new -Wl,-T,$(srcdir)/thumb2_branch_range.t -o $@ $<
+ ../ld-new -T $(srcdir)/thumb2_branch_range.t -o $@ $<
thumb2_bl_in_range.o: thumb_bl_in_range.s
$(TEST_AS) -o $@ -march=armv7-a $<
@@ -2425,7 +2425,7 @@ thumb2_bl_out_of_range.stdout: thumb2_bl_out_of_range
$(TEST_OBJDUMP) -D $< > $@
thumb2_bl_out_of_range: thumb2_bl_out_of_range.o ../ld-new
- ../ld-new -Wl,-T,$(srcdir)/thumb2_branch_range.t -o $@ $<
+ ../ld-new -T $(srcdir)/thumb2_branch_range.t -o $@ $<
thumb2_bl_out_of_range.o: thumb_bl_out_of_range.s
$(TEST_AS) -o $@ -march=armv7-a $<
@@ -2434,7 +2434,7 @@ thumb_blx_in_range.stdout: thumb_blx_in_range
$(TEST_OBJDUMP) -D $< > $@
thumb_blx_in_range: thumb_blx_in_range.o ../ld-new
- ../ld-new --no-fix-arm1176 -Wl,-T,$(srcdir)/thumb_branch_range.t -o $@ $<
+ ../ld-new --no-fix-arm1176 -T $(srcdir)/thumb_branch_range.t -o $@ $<
thumb_blx_in_range.o: thumb_blx_in_range.s
$(TEST_AS) -o $@ -march=armv5te $<
@@ -2443,7 +2443,7 @@ thumb_blx_out_of_range.stdout: thumb_blx_out_of_range
$(TEST_OBJDUMP) -D $< > $@
thumb_blx_out_of_range: thumb_blx_out_of_range.o ../ld-new
- ../ld-new --no-fix-arm1176 -Wl,-T,$(srcdir)/thumb_branch_range.t -o $@ $<
+ ../ld-new --no-fix-arm1176 -T $(srcdir)/thumb_branch_range.t -o $@ $<
thumb_blx_out_of_range.o: thumb_blx_out_of_range.s
$(TEST_AS) -o $@ -march=armv5te $<
@@ -2452,7 +2452,7 @@ thumb2_blx_in_range.stdout: thumb2_blx_in_range
$(TEST_OBJDUMP) -D $< > $@
thumb2_blx_in_range: thumb2_blx_in_range.o ../ld-new
- ../ld-new -Wl,-T,$(srcdir)/thumb2_branch_range.t -o $@ $<
+ ../ld-new -T $(srcdir)/thumb2_branch_range.t -o $@ $<
thumb2_blx_in_range.o: thumb_blx_in_range.s
$(TEST_AS) -o $@ -march=armv7-a $<
@@ -2461,7 +2461,7 @@ thumb2_blx_out_of_range.stdout: thumb2_blx_out_of_range
$(TEST_OBJDUMP) -D $< > $@
thumb2_blx_out_of_range: thumb2_blx_out_of_range.o ../ld-new
- ../ld-new -Wl,-T,$(srcdir)/thumb2_branch_range.t -o $@ $<
+ ../ld-new -T $(srcdir)/thumb2_branch_range.t -o $@ $<
thumb2_blx_out_of_range.o: thumb_blx_out_of_range.s
$(TEST_AS) -o $@ -march=armv7-a $<
@@ -2470,7 +2470,7 @@ thumb_bl_out_of_range_local.stdout: thumb_bl_out_of_range_local
$(TEST_OBJDUMP) -D $< > $@
thumb_bl_out_of_range_local: thumb_bl_out_of_range_local.o ../ld-new
- ../ld-new --no-fix-arm1176 -Wl,-T,$(srcdir)/thumb_branch_range.t -o $@ $<
+ ../ld-new --no-fix-arm1176 -T $(srcdir)/thumb_branch_range.t -o $@ $<
thumb_bl_out_of_range_local.o: thumb_bl_out_of_range_local.s
$(TEST_AS) -o $@ -march=armv5te $<
@@ -2479,7 +2479,7 @@ arm_thm_jump11.stdout: arm_thm_jump11
$(TEST_OBJDUMP) -D $< > $@
arm_thm_jump11: arm_thm_jump11.o ../ld-new
- ../ld-new -Wl,-T,$(srcdir)/arm_thm_jump11.t -o $@ $<
+ ../ld-new -T $(srcdir)/arm_thm_jump11.t -o $@ $<
arm_thm_jump11.o: arm_thm_jump11.s
$(TEST_AS) -o $@ $<
@@ -2488,7 +2488,7 @@ arm_thm_jump8.stdout: arm_thm_jump8
$(TEST_OBJDUMP) -D $< > $@
arm_thm_jump8: arm_thm_jump8.o ../ld-new
- ../ld-new -Wl,-T,$(srcdir)/arm_thm_jump8.t -o $@ $<
+ ../ld-new -T $(srcdir)/arm_thm_jump8.t -o $@ $<
arm_thm_jump8.o: arm_thm_jump8.s
$(TEST_AS) -o $@ $<