summaryrefslogtreecommitdiff
path: root/ld/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ld/Makefile.am')
-rw-r--r--ld/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/ld/Makefile.am b/ld/Makefile.am
index a0eb12578b..0ed8d22201 100644
--- a/ld/Makefile.am
+++ b/ld/Makefile.am
@@ -13,6 +13,9 @@ YACC = `if [ -f ../bison/bison ]; then echo ../bison/bison -y -L$(srcdir)/../bis
YFLAGS = -d
LEX = `if [ -f ../flex/flex ]; then echo ../flex/flex; else echo @LEX@; fi`
+WARN_CFLAGS = @WARN_CFLAGS@
+AM_CFLAGS = $(WARN_CFLAGS)
+
# We put the scripts in the directory $(scriptdir)/ldscripts.
# We can't put the scripts in $(datadir) because the SEARCH_DIR
# directives need to be different for native and cross linkers.