summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2012-01-16 12:29:19 +0100
committerJim Meyering <meyering@redhat.com>2012-01-19 09:09:38 +0100
commit85ad742d4e94345d5ac07755f6722344cfd49603 (patch)
tree130a7f0061285f938e7fc41394665e38a07eaa4c /Makefile.am
parent77f114dd6e50ab39e0962f39ad9c2f2e1d347acf (diff)
downloadbison-85ad742d4e94345d5ac07755f6722344cfd49603.tar.gz
build: manually update bootstrap from gnulib, and adapt
Updating to the latest bootstrap from gnulib involves more of a change than usual, and updating to the latest gnulib would involve its own set of challenges with the upcoming quoting changes, so we update bootstrap manually and separately. * bootstrap: Update from gnulib. * Makefile.am: Initialize more variables to empty, so that gnulib.mk can append to them with "+=". * bootstrap.conf (gnulib_mk_hook): Remove. No longer honored. (bootstrap_post_import_hook): Instead, run the same command, etc/prefix-gnulib-mk lib/$gnulib_mk, via slightly different API. Temporarily disable "bootstrap_sync=true". * etc/prefix-gnulib-mk: Don't prepend "lib/" to tokens like -I$(... or "\".
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7f7aa4be..2a9ad2b1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,6 +37,9 @@ BUILT_SOURCES =
DISTCLEANFILES =
MOSTLYCLEANFILES =
SUFFIXES =
+noinst_LIBRARIES =
+MOSTLYCLEANDIRS =
+
include build-aux/local.mk
include data/local.mk
include djgpp/local.mk