summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAkim Demaille <demaille@gostai.com>2008-09-23 15:54:56 +0200
committerAkim Demaille <demaille@gostai.com>2008-11-15 10:47:15 +0100
commit0305d25eb08b0128d759cc70370524f48bb47290 (patch)
tree659298d149a53860f07d3d9c8fe73ae9204ba96c /Makefile.am
parent5277c0a30453b4fb279022b467e3c7960d07fb2c (diff)
downloadbison-0305d25eb08b0128d759cc70370524f48bb47290.tar.gz
Remove src/Makefile.am.
* src/Makefile.am: Rename as... * src/local.mk: this. Prefix all the paths with src/. (AUTOMAKE_OPTIONS): Build object files in the sub dirs. (AM_CPPFLAGS): Find find in builddir/src. (YACC): Move the flags into... (AM_YFLAGS): here. * maint.mk (sc_tight_scope): Disable. It used to bounce to the version in src/Makefile.am which is now part of this very Makefile. * Makefile.am, configure.ac: Adjust. * src/scan-code-c.c, src/scan-code.l: We can no longer rely on include "..." to find files "here": we are no longer in src/, so qualify the includes with src/. * doc/Makefile.am (PREPATH): No longer include the top_builddir prefix. (.x.1): Adjust to be able to create src/foo from the top level Makefile, instead of going bounce to src/Makefile the creation of foo.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index dd20d5d0..f5f888d9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,7 +17,7 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = po runtime-po lib src doc tests
+SUBDIRS = po runtime-po lib . doc tests
if BISON_CXX_WORKS
SUBDIRS += examples/calc++
endif
@@ -33,10 +33,13 @@ EXTRA_DIST = .prev-version .version cfg.mk maint.mk \
djgpp/subpipe.c djgpp/subpipe.h djgpp/djunpack.bat \
djgpp/fnchange.lst djgpp/testsuite.sed
+# Initialization before completion by local.mk's.
+BUILT_SOURCES =
include build-aux/local.mk
include data/local.mk
include etc/local.mk
include examples/local.mk
+include src/local.mk
.PHONY: maintainer-check
maintainer-check:
@@ -59,7 +62,7 @@ maintainer-xml-check:
# a developer might naively reference .version in a test case while the bison
# executable still compiles with VERSION, and so the test case might fail or
# pass incorrectly.
-BUILT_SOURCES = $(top_srcdir)/.version
+BUILT_SOURCES += $(top_srcdir)/.version
$(top_srcdir)/.version: configure
echo $(VERSION) > $@-t && mv $@-t $@
dist-hook: