summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAkim Demaille <demaille@gostai.com>2009-08-12 14:47:08 +0200
committerAkim Demaille <demaille@gostai.com>2009-08-12 16:30:48 +0200
commit9f14e187368df7680c4c5313bd25e7f04de07ef0 (patch)
tree9554ffb6a537b6dfc5de17f956acadd6531fa2cb /Makefile.am
parentd1b55e811584638c9ebb7046e4017bba167bb072 (diff)
downloadbison-9f14e187368df7680c4c5313bd25e7f04de07ef0.tar.gz
build: fix the generation of the documentation.
Some of our targets use "bison --help", but they can't depend on "bison" itself (to avoid additional requirements on the user), so they used to call "make src/bison" in the commands. Then concurrent builds may fail: one make might be aiming one of its jobs at compiling src/bison, and another job at generating the man page. If the latter is faster than the former, then we have two makes that concurrently try to compile src/bison. This might also be a more convincing explanation for the failure described in the patch "build: fix paths". * Makefile.am (SUFFIXES): Initialize. * build-aux/move-if-change: New, symlink to gnulib's. * build-aux/local.mk: Ship it. * doc/common.x: Remove, merged into... * doc/bison.x: here. * doc/local.mk (doc/bison.help): New. ($(CROSS_OPTIONS_TEXI)): Depend on it. Use src/bison. (.x.1): Replace with... (doc/bison.1): this explicit, simpler, target. (common_dep): Remove, inlined where appropriate. (SUFFIXES, PREPATH): Remove, unused.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1bd44016..c507cc8e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -36,6 +36,7 @@ AM_CPPFLAGS =
BUILT_SOURCES =
DISTCLEANFILES =
MOSTLYCLEANFILES =
+SUFFIXES =
include build-aux/local.mk
include data/local.mk
include djgpp/local.mk