summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoel E. Denny <jdenny@ces.clemson.edu>2006-12-26 18:09:53 +0000
committerJoel E. Denny <jdenny@ces.clemson.edu>2006-12-26 18:09:53 +0000
commit2e7944cbb21e10c130192f733abc1af5cd8b6eb7 (patch)
treedd66a92c26c7646c98ce05b5833119c09f9f6002 /configure.ac
parentc3d503425f8014b432601a33b3398446d63b5963 (diff)
downloadbison-2e7944cbb21e10c130192f733abc1af5cd8b6eb7.tar.gz
Update etc/bench.pl. Optimize push mode a little (the yyn change
deserves most of the credit). * Makefile.am (SUBDIRS): Add etc subdirectory. * configure.ac (AC_CONFIG_FILES): Add etc/bench.pl and etc/Makefile. * data/push.c (b4_declare_parser_state_variables): Move yyn, yyresult, yytoken, yyval, and yyloc declarations to... (yyparse or yypush_parse): ... here to improve performance. For yypush_parse invocations after the first, be sure to assign yyn its old value again. (yypstate_new): Don't bother initializing the yyresult field since the initial value isn't used. (yyn, yyresult, yytoken, yyval, yyloc): For each NAME in this list, remove the #define that, in push mode, set it to yyps->NAME. * etc/Makefile.am: New. * etc/bench.pl: Remove and build it instead from... * etc/bench.pl.in: ... this new file. Use @abs_top_builddir@ to invoke "tests/bison" from the build directory by default rather than just invoking "bison" from $PATH. (calc_grammar): Update push parser code: don't declare yylval globally, don't define yyparse_wrapper, and don't #define yyparse. (bench_grammar): Update to check all working combinations of yacc.c, push.c, impure, pure, pull, and push.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 22bfb202..56a69b60 100644
--- a/configure.ac
+++ b/configure.ac
@@ -118,6 +118,9 @@ AC_CONFIG_FILES([runtime-po/Makefile.in])
aclocaldir='${datadir}/aclocal'
AC_SUBST([aclocaldir])
+# Create the benchmark script.
+AC_CONFIG_FILES([etc/bench.pl], [chmod +x etc/bench.pl])
+
# Initialize the test suite.
AC_CONFIG_TESTDIR(tests)
AC_CONFIG_FILES([tests/Makefile tests/atlocal])
@@ -137,6 +140,7 @@ AC_CONFIG_FILES([Makefile
build-aux/Makefile
po/Makefile.in
data/Makefile
+ etc/Makefile
examples/Makefile
examples/calc++/Makefile
lib/Makefile src/Makefile doc/Makefile])