summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAkim Demaille <akim@epita.fr>2000-09-18 13:01:59 +0000
committerAkim Demaille <akim@epita.fr>2000-09-18 13:01:59 +0000
commite79137accc7ea0352cd4677ff22818f9c68d4eab (patch)
tree780d1c3e9ccb43e045e23f4084fe627b4f1b94d0 /configure.in
parent8aa892b4613345bdbaa389536cba3f669b439b4d (diff)
downloadbison-e79137accc7ea0352cd4677ff22818f9c68d4eab.tar.gz
Add support for an Autotest test suite for Bison.
* m4/m4.m4, m4/atconfig.m4: New files. * m4/Makefile.am (EXTRA_DIST): Adjust. * tests/suite.m4, tests/Makefile.am, tests/atgeneral.m4: New files. * src/getargs.c: Display a more standard --version message. * src/reader.c (reader): Formatting changes. No longer depend upon VERSION_STRING. * configure.in: No longer use `dnl'. Set up the test suite and the new directory `tests/. (VERSION_STRING): Remove.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 21 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index a9e625b1..c2add60f 100644
--- a/configure.in
+++ b/configure.in
@@ -1,22 +1,25 @@
-dnl Process this file with autoconf to produce a configure script.
+# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.13)
AC_INIT(src/reduce.c)
AM_INIT_AUTOMAKE(bison, 1.28a)
AM_CONFIG_HEADER(config.h:config.hin)
-AC_DEFINE_UNQUOTED(VERSION_STRING, "GNU Bison version ${VERSION}",
- [The version string.])
-AC_DEFINE([_GNU_SOURCE],1,[Define to 1 for GNU C library extensions.])
-
-ALL_LINGUAS="de es et fr ja nl ru"
+# Initialize the test suite.
+AT_CONFIG(../src)
-dnl Checks for programs.
+# Checks for programs.
AC_PROG_CC
AC_MINIX
AC_ISC_POSIX
AM_PROG_CC_STDC
AC_PROG_INSTALL
AC_PROG_RANLIB
+# GNU M4 is needed to build the testsuite.
+BISON_AC_PROG_GNU_M4
+if test "$ac_cv_prog_gnu_m4" != yes; then
+ missing_dir=`cd $ac_aux_dir && pwd`
+ M4="$missing_dir/missing m4"
+fi
AC_ARG_ENABLE(gcc-warnings,
[ --enable-gcc-warnings turn on lots of GCC warnings (not recommended)],
@@ -41,26 +44,28 @@ if test "${enableval}" = yes; then
BISON_WARNING(-Wwrite-strings)
fi
-dnl Checks for libraries.
+# Checks for libraries.
+AC_DEFINE([_GNU_SOURCE],1,[Define to 1 for GNU C library extensions.])
-dnl Checks for header files.
+# Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS(ctype.h locale.h memory.h stdlib.h string.h unistd.h)
-dnl Checks for typedefs.
+# Checks for typedefs.
-dnl Checks for structures.
+# Checks for structures.
-dnl Checks for compiler characteristics.
+# Checks for compiler characteristics.
AC_C_CONST
AC_C_INLINE
AM_C_PROTOTYPES
-dnl Checks for library functions.
+# Checks for library functions.
AC_FUNC_ALLOCA
AC_CHECK_FUNCS(mkstemp setlocale)
BISON_NEED_DECLARATIONS(calloc realloc)
+ALL_LINGUAS="de es et fr ja nl ru"
AM_GNU_GETTEXT
jm_PREREQ_ERROR
@@ -71,4 +76,6 @@ AC_SUBST(LIBOBJS)
AC_OUTPUT([Makefile
intl/Makefile po/Makefile.in
- lib/Makefile src/Makefile doc/Makefile m4/Makefile])
+ lib/Makefile src/Makefile doc/Makefile
+ m4/Makefile
+ tests/Makefile tests/atconfig])