summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAkim Demaille <akim@epita.fr>2001-12-27 18:12:48 +0000
committerAkim Demaille <akim@epita.fr>2001-12-27 18:12:48 +0000
commitec2da99ffe7140db191d6683c493ad6936174311 (patch)
tree5dfd9e8d23b289b8e43cdbd1ee6a5261c9f5a713 /configure.in
parent8adfa272f72683102c45cc6eaba00aaa5db2497a (diff)
downloadbison-ec2da99ffe7140db191d6683c493ad6936174311.tar.gz
* configure.in: Check the protos of strchr ans strspn.
Replace strchr if needed. * src/system.h: Provide the protos of strchr, strspn and memchr if missing. * lib/strchr.c: New. * src/reader.c (symbols_save): Use strchr.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index b6788873..654b3a91 100644
--- a/configure.in
+++ b/configure.in
@@ -85,8 +85,8 @@ AC_FUNC_ALLOCA
AC_FUNC_OBSTACK
AC_FUNC_ERROR_AT_LINE
AC_CHECK_FUNCS(mkstemp setlocale)
-AC_CHECK_DECLS([stpcpy, strndup, strnlen, memchr])
-AC_REPLACE_FUNCS(stpcpy strndup strnlen strspn memchr)
+AC_CHECK_DECLS([stpcpy, strchr, strndup, strspn, strnlen, memchr])
+AC_REPLACE_FUNCS(stpcpy strchr strndup strnlen strspn memchr)
jm_FUNC_MALLOC
jm_FUNC_REALLOC
jm_PREREQ_QUOTEARG