summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am97
1 files changed, 42 insertions, 55 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a8f97e4..1658b78 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,68 +1,55 @@
AM_CPPFLAGS = $(GLIB_CFLAGS) $(DBUS_GLIB_CFLAGS)
AM_LDFLAGS = $(GLIB_LIBS) $(DBUS_GLIB_LIBS)
-# Marshallers generation
-#BUILT_SOURCES = lib/marshallers.c lib/marshallers.h
-#GENMARSHAL_FLAGS = --prefix="g_cclosure_bt_marshal" --g-fatal-warnings
-#
-#lib/marshallers.h: lib/marshallers.list
-# glib-genmarshal $(GENMARSHAL_FLAGS) --header lib/marshallers.list > lib/marshallers.h
-#
-#lib/marshallers.c: lib/marshallers.list
-# glib-genmarshal $(GENMARSHAL_FLAGS) --body lib/marshallers.list > lib/marshallers.c
-
-bluez_sources = lib/bluez/adapter.c lib/bluez/adapter.h \
- lib/bluez/agent.c lib/bluez/agent.h \
- lib/bluez/audio.c lib/bluez/audio.h \
+bluez_sources = lib/bluez/adapter.c lib/bluez/adapter.h \
+ lib/bluez/agent_manager.c lib/bluez/agent_manager.h \
+ lib/bluez/alert_agent.c lib/bluez/alert_agent.h \
+ lib/bluez/alert.c lib/bluez/alert.h \
+ lib/bluez/cycling_speed.c lib/bluez/cycling_speed.h \
+ lib/bluez/cycling_speed_manager.c lib/bluez/cycling_speed_manager.h \
lib/bluez/device.c lib/bluez/device.h \
- lib/bluez/input.c lib/bluez/input.h \
- lib/bluez/manager.c lib/bluez/manager.h \
+ lib/bluez/health_channel.c lib/bluez/health_channel.h \
+ lib/bluez/health_device.c lib/bluez/health_device.h \
+ lib/bluez/health_manager.c lib/bluez/health_manager.h \
+ lib/bluez/heart_rate.c lib/bluez/heart_rate.h \
+ lib/bluez/heart_rate_manager.c lib/bluez/heart_rate_manager.h \
+ lib/bluez/media.c lib/bluez/media.h \
+ lib/bluez/media_control.c lib/bluez/media_control.h \
+ lib/bluez/media_player.c lib/bluez/media_player.h \
lib/bluez/network.c lib/bluez/network.h \
lib/bluez/network_server.c lib/bluez/network_server.h \
- lib/bluez/serial.c lib/bluez/serial.h
-
-if OBEX
-obexd_sources = lib/obexd/obexagent.c lib/obexd/obexagent.h \
- lib/obexd/obexclient.c lib/obexd/obexclient.h \
- lib/obexd/obexclient_file_transfer.c lib/obexd/obexclient_file_transfer.h \
- lib/obexd/obexclient_session.c lib/obexd/obexclient_session.h \
- lib/obexd/obexclient_transfer.c lib/obexd/obexclient_transfer.h \
- lib/obexd/obexmanager.c lib/obexd/obexmanager.h \
- lib/obexd/obexsession.c lib/obexd/obexsession.h \
- lib/obexd/obextransfer.c lib/obexd/obextransfer.h
-else
-obexd_sources =
-endif
-
-lib_sources = lib/marshallers.c lib/marshallers.h \
+ lib/bluez/obex/obex_agent_manager.c lib/bluez/obex/obex_agent_manager.h \
+ lib/bluez/obex/obex_client.c lib/bluez/obex/obex_client.h \
+ lib/bluez/obex/obex_file_transfer.c lib/bluez/obex/obex_file_transfer.h \
+ lib/bluez/obex/obex_message_access.c lib/bluez/obex/obex_message_access.h \
+ lib/bluez/obex/obex_message.c lib/bluez/obex/obex_message.h \
+ lib/bluez/obex/obex_object_push.c lib/bluez/obex/obex_object_push.h \
+ lib/bluez/obex/obex_phonebook_access.c lib/bluez/obex/obex_phonebook_access.h \
+ lib/bluez/obex/obex_session.c lib/bluez/obex/obex_session.h \
+ lib/bluez/obex/obex_synchronization.c lib/bluez/obex/obex_synchronization.h \
+ lib/bluez/obex/obex_transfer.c lib/bluez/obex/obex_transfer.h \
+ lib/bluez/profile_manager.c lib/bluez/profile_manager.h \
+ lib/bluez/proximity_monitor.c lib/bluez/proximity_monitor.h \
+ lib/bluez/proximity_reporter.c lib/bluez/proximity_reporter.h \
+ lib/bluez/sim_access.c lib/bluez/sim_access.h \
+ lib/bluez/thermometer.c lib/bluez/thermometer.h \
+ lib/bluez/thermometer_manager.c lib/bluez/thermometer_manager.h
+
+lib_sources = lib/agent-helper.c lib/agent-helper.h \
lib/dbus-common.c lib/dbus-common.h \
lib/helpers.c lib/helpers.h \
+ lib/manager.c lib/manager.h \
+ lib/obex_agent.c lib/obex_agent.h \
+ lib/properties.c lib/properties.h \
lib/sdp.c lib/sdp.h \
lib/bluez-api.h
-if OBEX
-lib_sources += lib/obexd-api.h
-endif
-
-bin_PROGRAMS = bt-monitor bt-adapter bt-agent bt-device bt-input bt-audio bt-network bt-serial
-bt_monitor_SOURCES = $(lib_sources) $(bluez_sources) $(obexd_sources) bt-monitor.c
-bt_adapter_SOURCES = $(lib_sources) $(bluez_sources) $(obexd_sources) bt-adapter.c
-bt_agent_SOURCES = $(lib_sources) $(bluez_sources) $(obexd_sources) bt-agent.c
-bt_device_SOURCES = $(lib_sources) $(bluez_sources) $(obexd_sources) bt-device.c
-bt_input_SOURCES = $(lib_sources) $(bluez_sources) $(obexd_sources) bt-input.c
-bt_audio_SOURCES = $(lib_sources) $(bluez_sources) $(obexd_sources) bt-audio.c
-bt_network_SOURCES = $(lib_sources) $(bluez_sources) $(obexd_sources) bt-network.c
-bt_serial_SOURCES = $(lib_sources) $(bluez_sources) $(obexd_sources) bt-serial.c
-
-if OBEX
-bin_PROGRAMS += bt-obex
-bt_obex_SOURCES = $(lib_sources) $(bluez_sources) $(obexd_sources) bt-obex.c
+bin_PROGRAMS = bt-adapter bt-agent bt-device bt-network bt-obex
+bt_adapter_SOURCES = $(lib_sources) $(bluez_sources) bt-adapter.c
+bt_agent_SOURCES = $(lib_sources) $(bluez_sources) bt-agent.c
+bt_device_SOURCES = $(lib_sources) $(bluez_sources) bt-device.c
+bt_network_SOURCES = $(lib_sources) $(bluez_sources) bt-network.c
+bt_obex_SOURCES = $(lib_sources) $(bluez_sources) bt-obex.c
bt_obex_LDADD = $(LIBREADLINE)
-endif
-
-dist_man_MANS = bt-monitor.1 bt-adapter.1 bt-agent.1 bt-device.1 bt-input.1 bt-audio.1 bt-network.1 bt-serial.1
-if OBEX
-dist_man_MANS += bt-obex.1
-endif
-#CLEANFILES = lib/marshallers.c lib/marshallers.h
+dist_man_MANS = bt-adapter.1 bt-agent.1 bt-device.1 bt-network.1 bt-obex.1