summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorClaudio Takahasi <claudio.takahasi@openbossa.org>2010-11-18 16:07:34 -0200
committerJohan Hedberg <johan.hedberg@nokia.com>2010-11-18 22:00:02 +0200
commitf9523a9bf583d9979b0157f8615d2a914ee588e8 (patch)
tree87b9189230047e2b19b76cb52b5512d0eb0d3020 /Makefile.am
parent8022b94b0523b2bdb8a02d7d148eb58d4b189dd2 (diff)
downloadbluez-f9523a9bf583d9979b0157f8615d2a914ee588e8.tar.gz
Implement Discover Primary Service by Service UUID in the gatttool
Implement only the first interaction of the discovery procedure. If the response doesn't fit in the MTU, "start" and "end" options can be used to discover the handles ranges of the remaining primary service instances. UUID16 and UUID128 are supported in the uuid option. Usage example: $gatttool -i hcix -b xx:xx:xx:xx:xx:xx --uuid=1801 --primary
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 03a9bf22a..5f9697597 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -178,7 +178,8 @@ if ATTRIBPLUGIN
bin_PROGRAMS += attrib/gatttool
attrib_gatttool_SOURCES = attrib/gatttool.c attrib/att.c attrib/gatt.c \
- attrib/gattrib.c btio/btio.c
+ attrib/gattrib.c btio/btio.c \
+ src/glib-helper.h src/glib-helper.c
attrib_gatttool_LDADD = lib/libbluetooth.la @GLIB_LIBS@
builtin_modules += attrib