summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTedd Ho-Jeong An <tedd.an@intel.com>2021-05-03 22:02:06 -0700
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2021-05-04 16:49:02 -0700
commit1835be72e13f073f1765440bbd5167d0dd2747be (patch)
treed41f3460ad7cc77c13bbda63a792eabc6a4a91b1 /Makefile.am
parentb66f406e1e15fb7137412963b82ad143e4a4cd93 (diff)
downloadbluez-1835be72e13f073f1765440bbd5167d0dd2747be.tar.gz
src: Convert manpage to rst format
This patch converts the existing manpage for bluetoothd into reStructuredText format.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4e9cae885..52e0e9ed8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -345,7 +345,7 @@ CLEANFILES += $(builtin_files) src/bluetooth.service
if MANPAGES
man_MANS += src/bluetoothd.8
endif
-EXTRA_DIST += src/bluetoothd.8
+manual_pages += src/bluetoothd.8
EXTRA_DIST += src/genbuiltin src/bluetooth.conf \
src/main.conf profiles/network/network.conf \
@@ -631,6 +631,9 @@ endif
%.1: %.rst Makefile
$(RST2MAN_PROCESS)
+%.8: %.rst Makefile
+ $(RST2MAN_PROCESS)
+
src/builtin.h: src/genbuiltin $(builtin_sources)
$(AM_V_GEN)$(srcdir)/src/genbuiltin $(builtin_modules) > $@