summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2012-12-11 00:24:43 +0100
committerMarcel Holtmann <marcel@holtmann.org>2012-12-11 00:24:43 +0100
commit652229d7709b29432f9fdf9a36999a713b1600ed (patch)
tree027b3601759c2f7ebd52c84a2eb8ff997bf27c40 /configure.ac
parent9bb8b242019154e124b38f13a946d43044aa1a7f (diff)
downloadbluez-652229d7709b29432f9fdf9a36999a713b1600ed.tar.gz
build: Fix issue with tools dependencies
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 608e6b826..0ae5c2c26 100644
--- a/configure.ac
+++ b/configure.ac
@@ -103,7 +103,7 @@ AM_CONDITIONAL(TOOLS, test "${enable_tools}" = "yes")
AC_ARG_ENABLE(readline, AC_HELP_STRING([--disable-readline],
[disable readline support]), [enable_readline=${enableval}])
-if (test "${enable_tools}" != "no" && test "${enable_readline}" != "no" ); then
+if (test "${enable_tools}" = "yes" && test "${enable_readline}" != "no" ); then
AC_CHECK_HEADERS(readline/readline.h, dummy=yes,
AC_MSG_ERROR(readline header files are required))
fi
@@ -111,7 +111,7 @@ AM_CONDITIONAL(READLINE, test "${enable_readline}" != "no")
AC_ARG_ENABLE(usb, AC_HELP_STRING([--disable-usb],
[disable USB support]), [enable_usb=${enableval}])
-if (test "${enable_tools}" != "no" && test "${enable_usb}" != "no" ); then
+if (test "${enable_tools}" = "yes" && test "${enable_usb}" != "no" ); then
PKG_CHECK_MODULES(USB, libusb, dummy=yes,
AC_MSG_ERROR(USB library support is required))
AC_SUBST(USB_CFLAGS)
@@ -130,7 +130,7 @@ AM_CONDITIONAL(USB, test "${enable_usb}" != "no")
AC_ARG_ENABLE(udev, AC_HELP_STRING([--disable-udev],
[disable udev device support]), [enable_udev=${enableval}])
-if (test "${enable_udev}" != "no"); then
+if (test "${enable_tools}" = "yes" && test "${enable_udev}" != "no"); then
PKG_CHECK_MODULES(UDEV, libudev >= 143, dummy=yes,
AC_MSG_ERROR(libudev >= 143 is required))
AC_CHECK_LIB(udev, udev_hwdb_new,
@@ -153,8 +153,8 @@ AC_SUBST(UDEV_CFLAGS)
AC_SUBST(UDEV_LIBS)
AM_CONDITIONAL(UDEV, test "${enable_udev}" != "no")
-AM_CONDITIONAL(HID2HCI, test "${enable_udev}" != "no" &&
- test "${enable_usb}" != "no")
+AM_CONDITIONAL(HID2HCI, test "${enable_tools}" = "yes" &&
+ test "${enable_udev}" != "no" && test "${enable_usb}" != "no")
AM_CONDITIONAL(CUPS, test "${enable_tools}" = "yes")
AC_ARG_ENABLE(obex, AC_HELP_STRING([--disable-obex],