summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMarcel Hellkamp <marc@gsites.de>2009-07-30 11:07:28 +0200
committerMarcel Hellkamp <marc@gsites.de>2009-07-30 11:07:28 +0200
commit75bd9b38ab683bd259e46e4a370875a0e2bf3079 (patch)
tree6d7c986f995fa46f5f6f083913901e9436a72c8f /setup.py
parent621501f7e92be293b9abc2c7b4200c21c6da4b80 (diff)
downloadbottle-75bd9b38ab683bd259e46e4a370875a0e2bf3079.tar.gz
Re-added support for Python 2.5
setup.py now automatically runs 2to3 on Python3 builds.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 14 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index aeeb5f4..84c578e 100644
--- a/setup.py
+++ b/setup.py
@@ -1,17 +1,28 @@
#!/usr/bin/env python
from distutils.core import setup
+import sys
import bottle
+try:
+ from distutils.command.build_py import build_py_2to3 as build_py
+except ImportError:
+ from distutils.command.build_py import build_py
+
+if sys.version_info < (2,5):
+ raise NotImplementedError("Sorry, you need at least Python 2.6 or Python 3.x to use bottle.")
+
setup(name='bottle',
version=bottle.__version__,
description='Fast and simple WSGI-framework for small web-applications.',
- long_description='Bottle is a fast and simple mirco-framework for small web-applications. It offers request dispatching (Routes) with url parameter support, Templates, key/value Databases, a build-in HTTP Server and adapters for many third party WSGI/HTTP-server and template engines. All in a single file and with no dependencies other than the Python Standard Library.',
+ long_description='Bottle is a fast and simple micro-framework for small web-applications. It offers request dispatching (Routes) with url parameter support, Templates, key/value Databases, a build-in HTTP Server and adapters for many third party WSGI/HTTP-server and template engines. All in a single file and with no dependencies other than the Python Standard Library.',
author='Marcel Hellkamp',
author_email='marc@gsites.de',
url='http://bottle.paws.de/',
py_modules=['bottle'],
license='MIT',
+ platforms = 'any',
+ zip_safe = True,
classifiers=['Development Status :: 4 - Beta',
'Intended Audience :: Developers',
'License :: OSI Approved :: MIT License',
@@ -23,7 +34,8 @@ setup(name='bottle',
'Topic :: Internet :: WWW/HTTP :: WSGI :: Server',
'Topic :: Software Development :: Libraries :: Application Frameworks',
'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 3']
+ 'Programming Language :: Python :: 3'],
+ cmdclass = {'build_py': build_py}
)