summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 3 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index b2d94ce..bcedd9d 100755
--- a/setup.py
+++ b/setup.py
@@ -1,10 +1,7 @@
#!/usr/bin/env python
import sys
-try:
- from setuptools import setup
-except ImportError:
- from distutils.core import setup
+from setuptools import setup
if sys.version_info < (2, 7):
raise NotImplementedError("Sorry, you need at least Python 2.7 or Python 3.2+ to use bottle.")
@@ -15,6 +12,7 @@ setup(name='bottle',
version=bottle.__version__,
description='Fast and simple WSGI-framework for small web-applications.',
long_description=bottle.__doc__,
+ long_description_content_type="text/markdown",
author=bottle.__author__,
author_email='marc@gsites.de',
url='http://bottlepy.org/',
@@ -23,6 +21,7 @@ setup(name='bottle',
license='MIT',
platforms='any',
classifiers=['Development Status :: 4 - Beta',
+ "Operating System :: OS Independent",
'Intended Audience :: Developers',
'License :: OSI Approved :: MIT License',
'Topic :: Internet :: WWW/HTTP :: Dynamic Content :: CGI Tools/Libraries',