summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDarius Makovsky <traveltissues@protonmail.com>2019-11-27 16:57:32 +0000
committerDarius Makovsky <traveltissues@protonmail.com>2019-11-27 16:57:32 +0000
commit528b33bddf383b2f46457a12c88b07cba47ff8d6 (patch)
tree38b41fdb7e8465f814fe507efa342f1b4c67f362
parentf21d0859b4480e1eb1cb891bff0fad5788d10639 (diff)
parent11f3f7055cf7705d04819398ad42e3a6e805652c (diff)
downloadbuildstream-528b33bddf383b2f46457a12c88b07cba47ff8d6.tar.gz
Merge branch 'abderrahim/backport-947' into 'bst-1'
plugins/elements/cmake.yaml: always specify variable types See merge request BuildStream/buildstream!1549
-rw-r--r--buildstream/plugins/elements/cmake.yaml2
-rw-r--r--tests/format/variables.py4
2 files changed, 3 insertions, 3 deletions
diff --git a/buildstream/plugins/elements/cmake.yaml b/buildstream/plugins/elements/cmake.yaml
index b51727b04..0eca2b3b8 100644
--- a/buildstream/plugins/elements/cmake.yaml
+++ b/buildstream/plugins/elements/cmake.yaml
@@ -19,7 +19,7 @@ variables:
cmake-args: |
-DCMAKE_INSTALL_PREFIX:PATH="%{prefix}" \
- -DCMAKE_INSTALL_LIBDIR=%{lib} %{cmake-extra} %{cmake-global} %{cmake-local}
+ -DCMAKE_INSTALL_LIBDIR:PATH="%{lib}" %{cmake-extra} %{cmake-global} %{cmake-local}
cmake: |
diff --git a/tests/format/variables.py b/tests/format/variables.py
index d01d87e5b..098837af3 100644
--- a/tests/format/variables.py
+++ b/tests/format/variables.py
@@ -20,7 +20,7 @@ DATA_DIR = os.path.join(
('autotools.bst', 'make-install', "make -j1 DESTDIR=\"/buildstream-install\" install"),
('cmake.bst', 'cmake',
"cmake -B_builddir -H. -G\"Unix Makefiles\" -DCMAKE_INSTALL_PREFIX:PATH=\"/usr\" \\\n" +
- "-DCMAKE_INSTALL_LIBDIR=lib "),
+ "-DCMAKE_INSTALL_LIBDIR:PATH=\"lib\" "),
('distutils.bst', 'python-install',
"python3 setup.py install --prefix \"/usr\" \\\n" +
"--root \"/buildstream-install\""),
@@ -46,7 +46,7 @@ def test_defaults(cli, datafiles, tmpdir, target, varname, expected):
('autotools.bst', 'make-install', "make -j1 DESTDIR=\"/custom/install/root\" install"),
('cmake.bst', 'cmake',
"cmake -B_builddir -H. -G\"Ninja\" -DCMAKE_INSTALL_PREFIX:PATH=\"/opt\" \\\n" +
- "-DCMAKE_INSTALL_LIBDIR=lib "),
+ "-DCMAKE_INSTALL_LIBDIR:PATH=\"lib\" "),
('distutils.bst', 'python-install',
"python3 setup.py install --prefix \"/opt\" \\\n" +
"--root \"/custom/install/root\""),