diff options
author | Tristan Van Berkom <tristan.vanberkom@codethink.co.uk> | 2017-05-08 20:37:11 +0900 |
---|---|---|
committer | Tristan Van Berkom <tristan.vanberkom@codethink.co.uk> | 2017-05-08 20:37:11 +0900 |
commit | 090499f81b03cecf64fd756d35e922d88df7d042 (patch) | |
tree | 1651bb835bb5bd870fcbd0f6261be16642b8335e /setup.py | |
parent | 640a734ec1db923b5a0025acdd0a1e8e031a013b (diff) | |
download | buildstream-090499f81b03cecf64fd756d35e922d88df7d042.tar.gz |
setup.py: Use setuptools_scm plugin
This plugin automatically encodes git versioning information
into the package version string so that it shows up in `bst --version`
This versioning information is encoded into source distributions
as well, so that when installing from a source distribution without
the git repository the precise VCS provenance is still encoded into
the version.
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -96,6 +96,7 @@ setup(name='BuildStream', version='0.1', description='A framework for modelling build pipelines in YAML', license='LGPL', + use_scm_version=True, packages=find_packages(), package_data={'buildstream': ['plugins/*/*.py', 'plugins/*/*.yaml', 'data/*.yaml']}, data_files=[('share/man/man1', list_man_pages())], @@ -112,7 +113,7 @@ setup(name='BuildStream', build-stream=buildstream._frontend:cli bst=buildstream._frontend:cli ''', - setup_requires=['pytest-runner'], + setup_requires=['pytest-runner', 'setuptools_scm'], tests_require=['pep8', 'coverage', 'pytest-datafiles', |