summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2016-12-17 15:32:38 +0900
committerTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2016-12-17 15:51:04 +0900
commit991d47672f174c858fe533dc9775e654133c007c (patch)
tree56108af7b559417652be2932c98ba9fc1666dacd /setup.py
parentd1c097451de22cc9180e953207c1cca223450c36 (diff)
downloadbuildstream-991d47672f174c858fe533dc9775e654133c007c.tar.gz
setup.py: Require at least python 3.5
We require ostree from July 2016 and we also require bubblewrap, both of which are more recent than python 3.5 which was released in September 2015. There is no point to have version conditional code here or support earlier versions of python.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index c776a217a..7e8716378 100755
--- a/setup.py
+++ b/setup.py
@@ -20,6 +20,10 @@
import sys
+if sys.version_info[0] != 3 or sys.version_info[1] < 5:
+ print("BuildStream requires Python >= 3.5")
+ sys.exit(1)
+
try:
from setuptools import setup, find_packages
except ImportError: